+ Start a Discussion
Deepak Kumar ShyoranDeepak Kumar Shyoran 

Problem in generating metadata WSDL from developer edition.

 

Hi All,

 

 

 

 

I trying to generate the metadata WSDL from  my salesfroce for that I follow the following steps.

 

 1-  Login into my account with admin profile 

 

 

 2-  Go to setup-->Develop-->Api-->Then click on Generate Metadata Api WSDL but it show this message 

 

 

Check the current status of an asyncronous deploy call. Check the current status of an asyncronous deploy call. Check the current status of an asyncronous call. Creates new metadata entries asyncronously. Deletes metadata entries asyncronously. Deploys a zipfile full of metadata entries asynchronously. Describes features of the metadata API. Lists the available metadata components. Retrieves a set of individually specified metadata entries. Updates metadata entries asyncronously. Manage your Salesforce.com metadata

 


please suggest me the way so that i can generate WSDL 

 

Any help will be appreciated

 

Thanks 

Deepak Shyoran

 

 

 

 

 

 

 

 

Best Answer chosen by Admin (Salesforce Developers) 
Avidev9Avidev9
If everything fails blame it on Browser!
(Because I got the page momentarily and then it navigated to the WSDL)
Try with a Chrome/Firfox

All Answers

Avidev9Avidev9

Tried to do the same and was able to get the WSDL.

 

Try this if this helps https://ap1.salesforce.com/services/wsdl/metadata

Change this server instance to your server instance

Deepak Kumar ShyoranDeepak Kumar Shyoran

Thanks for your response, I have tried the above approach but I get the same message as explained above . I have tried this one from my 3-4 different org but get the same result . Do I need to make some changes in org or does it need some permission please  explain.

 

Thanks 

Deepak Shyoran

Avidev9Avidev9
I dont think you need anything other than "Author Apex". I just checked with my DE org and it works good.

Tried

Develop > Api > Generate Metadata WSDL >> Gives the WSDL

I havent seen such a message.
Avidev9Avidev9

You need the "API Enabled" permission to generate WSDLs.

Avidev9Avidev9
If everything fails blame it on Browser!
(Because I got the page momentarily and then it navigated to the WSDL)
Try with a Chrome/Firfox
This was selected as the best answer
Deepak Kumar ShyoranDeepak Kumar Shyoran

I was unable to fetch WSDL in chrome but it works fine in IE . Thanks for your help.

 

Thanks

Deepak Shyoran