+ Start a Discussion
BpositiveBpositive 

Installation of Force.com IDE plugin for eclipse error

Cannot complete the install because of a conflicting dependency.
Software being installed: Force.com IDE 25.0.0.201206181021 (com.salesforce.ide.feature.feature.group 25.0.0.201206181021)
Software currently installed: Eclipse IDE for Java Developers 1.3.1.20100916-1202 (epp.package.java 1.3.1.20100916-1202)
Only one of the following can be installed at once:
International Components for Unicode for Java (ICU4J) 4.2.1.v20100412 (com.ibm.icu 4.2.1.v20100412)
International Components for Unicode for Java (ICU4J) 4.0.1.v20090822 (com.ibm.icu 4.0.1.v20090822)
Only one of the following can be installed at once:
Structured Source Editor 1.2.2.v201008232126 (org.eclipse.wst.sse.ui 1.2.2.v201008232126)
Structured Source Editor 1.1.102.v200910200227 (org.eclipse.wst.sse.ui 1.1.102.v200910200227)
Cannot satisfy dependency:
From: Force.com IDE 25.0.0.201206181021 (com.salesforce.ide.feature.feature.group 25.0.0.201206181021)
To: org.eclipse.wst.html.ui [1.0.0,2.0.0)
Cannot satisfy dependency:
From: Eclipse IDE for Java Developers 1.3.1.20100916-1202 (epp.package.java 1.3.1.20100916-1202)
To: org.eclipse.epp.package.java.feature.feature.group [1.3.1.20100916-1202]
Cannot satisfy dependency:
From: EPP Java Package 1.3.1.20100916-1202 (org.eclipse.epp.package.java.feature.feature.group 1.3.1.20100916-1202)
To: org.eclipse.rcp.feature.group 3.6.0
Cannot satisfy dependency:
From: EPP Java Package 1.3.1.20100916-1202 (org.eclipse.epp.package.java.feature.feature.group 1.3.1.20100916-1202)
To: org.eclipse.wst.xml_ui.feature.feature.group 0.0.0
Cannot satisfy dependency:
From: Java EMF Model Utilities 2.0.201.v201001252130 (org.eclipse.jem.util 2.0.201.v201001252130)
To: bundle com.ibm.icu [3.8.1.1,4.1.0)
Cannot satisfy dependency:
From: Eclipse RCP 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T (org.eclipse.rcp.feature.group 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T)
To: com.ibm.icu [4.2.1.v20100412]
Cannot satisfy dependency:
From: WST Common Core 3.1.1.v200908102300-7B77FZ6F7RZHKDIwRlOwUN (org.eclipse.wst.common_core.feature.feature.group 3.1.1.v200908102300-7B77FZ6F7RZHKDIwRlOwUN)
To: org.eclipse.jem.util [2.0.201.v201001252130]
Cannot satisfy dependency:
From: WST Common UI 3.1.1.v200908102300-7B5FRHDhdMOGnoekn4gtEJxSmPxV (org.eclipse.wst.common_ui.feature.feature.group 3.1.1.v200908102300-7B5FRHDhdMOGnoekn4gtEJxSmPxV)
To: org.eclipse.wst.common_core.feature.feature.group [3.1.1.v200908102300-7B77FZ6F7RZHKDIwRlOwUN]
Cannot satisfy dependency:
From: HTML UI Source Editor 1.0.401.v200908111935 (org.eclipse.wst.html.ui 1.0.401.v200908111935)
To: bundle org.eclipse.wst.sse.ui [1.1.0,1.2.0)
Cannot satisfy dependency:
From: Eclipse XML Editors and Tools 3.1.1.v200907161031-7H6FMbDxtkMs9OeLGF98LRhdPKeo (org.eclipse.wst.xml_ui.feature.feature.group 3.1.1.v200907161031-7H6FMbDxtkMs9OeLGF98LRhdPKeo)
To: org.eclipse.wst.common_ui.feature.feature.group [3.1.1.v200908102300-7B5FRHDhdMOGnoekn4gtEJxSmPxV]
Cannot satisfy dependency:
From: Eclipse XML Editors and Tools 3.2.2.v201008170029-7H7AFUQDxumQGOpBqffOY2f1qxDZ (org.eclipse.wst.xml_ui.feature.feature.group 3.2.2.v201008170029-7H7AFUQDxumQGOpBqffOY2f1qxDZ)
To: org.eclipse.wst.sse.ui [1.2.2.v201008232126]

 

I get the error above. How can I solve this? Please help me

 

Thank you

 

~VK

Best Answer chosen by Admin (Salesforce Developers) 

All Answers

JitendraJitendra
This was selected as the best answer
BpositiveBpositive

Dear Jitendra,

Thank you very much. Appreciated.

Syam SSyam S
Encountered the same error. The above link isn't working anymore. Can anyone provide a solution for this issue.