+ Start a Discussion
jontkjontk 

Axis 1.3 and compression

Has anyone had any luck getting the Axis 1.3 version with compression to work?
I followed the note's on the pocketsoap website and in addition I had to get the commons-httpclient-3.0 release candidate version and commons-codec-1.3 version.

I seem to have it partially working but am getting the error below...

org.apache.commons.httpclient.MultiThreadedHttpConnectionManager - Unable to get a connection, waiting..., hostConfig=HostConfiguration[host=https://na1-api.salesforce.com]

...when it tries to do a decribe call on an entity after it's already done a couple of successful describe calls before hand. From there it seems to hang indefinitely.

Anyone else experience this?

Thanks,
Jon
EatEat
I've experienced the same thing, in a warehousing app. On my 4th describeSObject call (to AccountTeamMember), the program just hangs.

I've turned off compression for now.

But would like a solution.

J
preeteepreetee

Hi,

I faced exactly the same problem. I am still trying to get a solution. Please post the solution if you get it.

Thanks,

Preetee

ccracyccracy
Hi,

I am facing the same problem. Has anybody been able to fix this.

This does not happen when I work from a standalone Java program. However, when I try to connect to Salesforce from a servlet, the connection hangs.

I am using Tomcat 5.5 as my web server. I have set the protocol as HTTP 1.1 with compression "on".

The connection does not hang after few exact number of calls made to salesforce. Sometimes it hangs after 2 queries, sometimes after 10-12 queries.

I am using axis 1.4.

Please advice.

Thanks,
Rohit M.