+ Start a Discussion
Force2b_MikeForce2b_Mike 

Unable to deploy Change Set from Winter '13 Sandbox to Summer '12 Production Org

I've run into a very strange error trying to deploy a Change Set into Production today.

 

I uploaded a Change Set around 2pm Eastern and that deployed fine, though I had a Deployment Error. I made a small change in the Sandbox and re-uploaded the Change Set into Production. Now when I try to open the Change Set in Production I get the following error message.

"The AppExchange Application or component you have selected is not yet available on your instance of salesforce.com. Please check back in a few days to retry the installation. Press the back button of your browser now and bookmark the AppExchange Directory page so that you can find it later."

This really makes no sense. Why would the Change Set I uploaded a few hours ago "work" and the new one not work? Plus, why does the error message talk about the "AppExchange"? The absolute worst part is checking back in a few days. At this point, I'm half way through a major deployment and unable to continue.

Best Answer chosen by Admin (Salesforce Developers) 
Force2b_MikeForce2b_Mike

Since that error message was so odd, I decided this morning to simply clone the Change Set and re-upload. Now it works. Very weird behavior. Maybe something happened to the original change set during the upload?

All Answers

Force2b_MikeForce2b_Mike

Since that error message was so odd, I decided this morning to simply clone the Change Set and re-upload. Now it works. Very weird behavior. Maybe something happened to the original change set during the upload?

This was selected as the best answer
Srikanth61Srikanth61

Thanks Man! It did work for me!! Had the same **bleep** issue. Took me 2 days to find out.