+ Start a Discussion
fsiddiq3fsiddiq3 

Connect Eclipse 3.5 SDK to Sandbox Instructions

Hello,

 

   I have just downloaded Eclipse 3.5 SDK. Can someone please guide me to how to connect this to my sandbox? I am having difficulty finding any instructions on this, any help would be greatly appreciated, thanks!

 

 

 

 

Fahad

NasipuriNasipuri

Hi,

 

Unfortunately the Force.com IDE is not supported on Eclipse version 3.5.

 

For detail please visit the link below :

 

http://wiki.developerforce.com/index.php/Force.com_IDE

 

Thanks,

Dinesh Nasipuri

Dinesh.Nasipuri@gmail.com

fsiddiq3fsiddiq3

Thanks Dinesh,

 

  I actually downloaded eclipse 3.4.2 and then got the IDE. I am trying to migrate a piece of apex code from sandbox to production, however I am getting the following error.

 

Failure and Warnings: Average test coverage across all Apex Classes and Triggers is 67% ....

 

 

I did not have this issue before, but am having it now. I am simply trying to migrate a apex class from sandbox to production. Any ideas? Please let me know, thanks

 

Fahad

 

NasipuriNasipuri

Hi Fahad,

 For Deploying Apex in production system , we need to have at least 75% of Apex scripts are covered by unit tests, and all of those tests complete successfully . For detail about the unit test and deployment please visit the "Apex Code Developer Guide" . 

Thanks,

Dinesh Nasipuri

Message Edited by Nasipuri on 09-08-2009 07:29 AM
fsiddiq3fsiddiq3
Hi Dinesh, So do I need to grab another apex or page? I am confused by this error message. Can you guide me thru this?
fsiddiq3fsiddiq3

I also ran a coverage test for the apex class I am trying to overwrite, the coverage for that class is 0%. Since this is 0%, this is causing the average for the rest of the classes to be 67% and not the 75% needed to execute the scripts. However, how do I increase the coverage %? Please help! Thanks

 

Fahad