+ Start a Discussion
dandantedandante 

SSLHandshakeException and ValidatorException in websphere but not tomcat (same JDK)

Hi All,

I read all the threads about this but I'm still having this issue.
I've been developing an application and it runs fine under tomcat.

When I deploy it under Websphere Community Edition 1.0.1.1, my login to salesforce fails with the following exception message:
nested exception is: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: No trusted certificate found
And part of the stack trace:

javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: No trusted certificate found
        at org.apache.axis.AxisFault.makeFault(AxisFault.java:101)
        at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:154)
        at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
        at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
        at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
        at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165)
        at org.apache.axis.client.Call.invokeEngine(Call.java:2784)
        at org.apache.axis.client.Call.invoke(Call.java:2767)
        at org.apache.axis.client.Call.invoke(Call.java:2443)
        at org.apache.axis.client.Call.invoke(Call.java:2366)
        at org.apache.axis.client.Call.invoke(Call.java:1812)
        at com.sforce.soap.partner.SoapBindingStub.login(SoapBindingStub.java:1062)

Here's the url that I'm trying to connect to:
https://www.salesforce.com/services/Soap/u/7.0

It's the same URL in tomcat and websphere.

Please note that tomcat and websphere are running under the exact same JDK, namely Sun 1.4.2_11.

Most of the threads about this error say you can solve it by upgrading your JDK. I am already running the highest 1.4x JDK and Websphere does not run (as far as I can tell) under java 1.5x.

Other threads had instructions about upgrading the certificates stored in JAVA_HOME/jre/lib/security/cacerts. I followed those instructions to the letter and that did not help or change the situation--the app still works on Tomcat 5.0.28 but not Websphere.

Hope someone can help. I am developing this app under tomcat but it needs to be deployed to websphere.




EnderEnder
Dandante,

You are correct in what you have read in the board searches.  I have seen these issues for over 2 years now (or when ever those certificates in JDK 1.4.x expired)  and in every case a lower version of the jdk has been the issue.

I believe that Websphere is not running against 1.4.2_11.   Besides typing java -version at the command prompt -- try something bizarre, like deleting 1.4.2_11 or renaming it, and see if websphere still works.  I'm thinking that Websphere installed a JRE when it installed, and the Websphere JRE was one of the ones with the expired certificates. 

Either that or find every lower instance of java installed on the computer and remove it. 

Some configuration is allowing tomcat to pick up the correct certs, but not Websphere. 


dandantedandante
I actually tried that--I renamed the jdk 1.4.2_11 directory and started websphere, and it complained in its log file about not being able to find the jdk, and stopped.

I tried the same with tomcat.

So I feel pretty sure they are using the same JDK.

There should not be any lower JDK's around (though there is a 1.5 JDK). I'll make double sure of this.

This makes it seem like an issue with websphere. Is there anything else I can try?
Thanks....

Message Edited by dandante on 04-19-2006 11:53 AM

SuperfellSuperfell
This sounds very websphere specific, you'll probably be able to get better help by asking the websphere folks.
bvoldbvold

Ok - since I ran into this problem and someone might benefit here's the issue:

WebSphere's JVM actually validates that the certificates that are embedded in the JDK are in fact valid.  Once I discovered this, you can either upgrade to a newer VM, or you can actually replace the bad certificates in the JDK (in the JRE directory of WebSphere in the WebSphere case).  Here's the relevant URL from the Sunsolve site:  http://sunsolve.sun.com/search/document.do?assetkey=1-26-57436-1