+ Start a Discussion
yem583yem583 

Lead Conversion Doesn't Trigger Workflow Rule

It appears that my workflow rule which should be triggered when a lead record is updated and the lead status = closed - converted, only is triggered if I click edit and manually update the status.  My rule is not triggered when I click lead conversion even though the status is updated to closed - converted.  Is there anyway to trigger a workflow rule when a lead is converted?
benjasikbenjasik
Workflow should fire. If it isn't, and you have a reproducible test case, please log a case so we can try to reproduce it.
yem583yem583

Where do I go to log a case?

benjasikbenjasik
You need to do it in a paying account, it's under help menu. If you only have a developer edition account, let us know and we can take this offline
WhyserWhyser
I'm having the exact same issue as well....
 
I had a workflow rule that would trigger an email alert (and dependent on some other criteria), and it seemed to have worked fine before the '08 release. After the '08 release, users who were supposed to get the email alert are noticing that they aren't getting them anymore.
 
I have created a new workflow just to "test" whether workflow rules on conversions work.. my rule is
 
Rule Criteria: Lead: Converted equals True
Evaluation Criteria: Created or Edited and did not previously meet the rule criteria
 
Workflow Rule is set to active, and it sends an email to my team.
 
So basically it should be sending my team an email whenever ANY lead is converted. And thus far, we haven't received any email at all.
 
 
trublutrublu

could you please advise if you got your workflow to fire please?

 

I have the same issue and now is already post summer 2009.

 

would logging a ticket with premier support help?

 

thank you very much.

WhyserWhyser

Not sure if this will work, but try this:

 

Under Setup -> App Setup -> Customize -> Leads -> Settings

 

There is is a checkbox that says, "Enforce Validation and Triggers from Lead Convert"

Make sure that is checked.

 

Hope that helps!

Message Edited by Whyser on 07-17-2009 12:49 PM
trublutrublu

Whyser,

Thank you very much for your reply!

 

We only have the following checkboxes available for some reason....

 

1. Lead Queue Settings:
The queue or user that will own a lead when assignment rules fail to locate an owner:
  • when a lead is saved with the auto-assign checkbox selected
  • when a lead is captured online

Notify Default Lead Owner  <= a CHECKBOX.

2. Lead Conversion Settings:
Do Not Change Lead Status Values to New Owner's Record Type on Lead Conversion  <= a CHECKBOX.

 

 

**** Did you have to log a case to enable this feature? I read another post below..

 

Enable Workflow on Lead Conversion for Everyone
http://ideas.salesforce.com/article/show/10092951/Enable_Workflow_on_Lead_Conversion_for_Everyone

 

Thank you very much!!!

WhyserWhyser

@trublu

 

no prob, check this out

 

https://na5.salesforce.com/help/doc/en/customize_leadsettings.htm

 

Looks like it will run your workflow actions according to the descriptions on that page. 

 

It also says it's available in Group, Professiona, Enterprise, Unlimited, and Developer Editions... is that what your Salesforce instance is? Sounds like it covers everything though.

 

What about permissions, does your profile have "Customize Application" checked?

 

If all these things check out, then I think your next best move is to log a case to Salesforce asking why this isn't there.

trublutrublu

Thank you, Whyser!

 

I will log a case, as I already have the system admin profile!

 

 

Karthikeyan MBKarthikeyan MB
Lead Setting
This is the setting and the popu explains the actions. Hope this helps