+ Start a Discussion
santhoshgsanthoshg 

When I am installing Eclipse in my Lap I face this error

An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Problems downloading artifact: osgi.bundle,com.salesforce.ide.api,28.0.0.201307091110.
MD5 hash is not as expected. Expected: 2baf6bd485903f59fd75f64b02bba49a and found e138e1088b3201b173a475e12a200f2f.
Unable to read repository at http://www.adnsandbox.com/tools/ide/install/plugins/com.salesforce.ide.core_28.0.0.201307091110.jar.
Read timed out
Problems downloading artifact: osgi.bundle,com.salesforce.ide.documentation,28.0.0.201307091110.
MD5 hash is not as expected. Expected: 211b4c6b1b052b6f045a2ddab7727d5b and found 8d26c0441c4c93ac41a317b7aa7be269.
Problems downloading artifact: osgi.bundle,com.salesforce.ide.ui.editors,28.0.0.201307091110.
MD5 hash is not as expected. Expected: 6102b001cf5df768247999ec46f7113c and found bb87fca20333671e25a029a270de51e9.

Ashish_SFDCAshish_SFDC

Hi Santosh, 

 

Download plugin jar files manually and put them into eclipse installation directory. The problem was in corrupted (partial) download of jars by eclipse.

  1. Download all jars of particular needed version fromhttp://www.adnsandbox.com/tools/ide/install/features/ andhttp://www.adnsandbox.com/tools/ide/install/plugins/ Make sure to use some download manager to ensure files integrity!
  2. Then put them to /features/ and /plugins/ folders of your eclipse installation directory accordingly.
  3. Run plugin installation as described by salesforce (Jars will not be downloaded again) 

Regards,

Ashish

santhoshgsanthoshg

Hi Ashish I was put all JAR files in feature and plugin folders,but It again one error that is Cannot complete the install because one or more required items could not be found. Software being installed: Force.com IDE 28.0.0.201307091110 (com.salesforce.ide.feature.feature.group 28.0.0.201307091110) Missing requirement: Force.com IDE 28.0.0.201307091110 (com.salesforce.ide.feature.feature.group 28.0.0.201307091110) requires 'org.eclipse.update.ui 0.0.0' but it could not be found