+ Start a Discussion
martin1122martin1122 

Unable to fetch organization details for 'username'; Connection refused: connect

I just installed the Force.com IDE on my computer. And tried to create a Force.com project using IDE, but kept failing as follows;

 

<Errors on the pop-up window>

Unable to fetch organization details for 'username'; Connection refused: connect

 

To ignore this error and create an empty Force.com Project without connecting to the server, click Create Office.

<Create Offline>  <Abort>  <Retry>

 

 

< Log file information : first 10 lines and last 10 lines>

WARN [2012-04-04 13:49:11,385] (BaseRetryAspect.java:isLoginExceptionRetryable:95) - Login evaluation deemed exception not retry-able:
 ConnectException: Connection refused: connect
 WARN [2012-04-04 13:49:11,410] (BaseRetryAspect.java:isConnectionExceptionRetryable:131) - Connection evaluation deemed exception not retry-able:
 ConnectException: Connection refused: connect
 WARN [2012-04-04 13:49:11,432] (ProjectController.java:getRemotePackageNames:882) - Unable to get project packages for project 'myDEVEnvironment': Connection refused: connect
 WARN [2012-04-04 13:49:11,462] (ProjectOrganizationPage.java:prepareNextPage:271) - Unable to load org details - package names and component enablement
java.net.ConnectException: Connection refused: connect
 at java.net.PlainSocketImpl.socketConnect(Native Method)
 at java.net.PlainSocketImpl.doConnect(Unknown Source)
 at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
 at java.net.PlainSocketImpl.connect(Unknown Source)
 at java.net.SocksSocketImpl.connect(Unknown Source)

(  . . . . . . . . . . . . )


 at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
 at java.lang.reflect.Method.invoke(Unknown Source)
 at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
 at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
 at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
 

Thank you very much for your tips and help

Martin

 

sfdcfoxsfdcfox

Check your firewall to ensure that this program has access, and also check your proxy settings, if any. Check iptables or netstat to make sure that Eclipse is actually getting to the server. Connection refused is almost always a problem with a firewall or proxy, though.

Amit LuniyaAmit Luniya

I think this post is little old one but still want to share the solution that worked for me.

 

You may face this issue because of firewall settings and configuring proxy server settings will do the trick.

Please go through my below blog for detailed steps of the solution.

 

http://aluniya.blogspot.com/2013/12/unable-to-fetch-organization-details-for.html

 

Please Accept my answer as solution (if it was helpful) to make it available to others for similar problem & Don't forget to give me KUDOS by Clicking on STAR icon