+ Start a Discussion
DodiDodi 

Dataloader - disable logs while running in batch

Is there a setting where I can disable the log files for a batch data loader process. I am loading high volumes and don't want to manage the log files and the log directory grows very rapidly. Any parameters in the log4J config file  to just disable them entirley.

 

Thanks

Best Answer chosen by Admin (Salesforce Developers) 
DodiDodi

I already had the debugMessages set to false and no entry at al for the debugMessagesFile.

 

I was able to stop the logs entirley from writing by removing the process.statusOutputDirectory entirley from the process-config.

 

Thanks for your help.

 

All Answers

Ritesh AswaneyRitesh Aswaney

I would try setting sfdc.debugMessages = false and supplying no value in the sfdc.debugMessagesFile property. (in the process-conf.xml)

 

https://emea.salesforce.com/help/doc/en/loader_params.htm

 

sfdc.debugMessagesbooleanN/AIf true, enables SOAP message debugging. By default, messages are sent to STDOUT unless you specify an alternate location in sfdc.debugMessagesFile.

Sample value: false

sfdc.debugMessagesFilestring (file name)N/ASee process.enableExtractSuccessOutput . Stores SOAP messages sent to or from Salesforce. As messages are sent or received, they are appended to the end of the file. As the file does not have a size limit, please monitor your available disk storage appropriately.

Sample value: \lexiloader\status\sfdcSoapTrace.log

DodiDodi

I already had the debugMessages set to false and no entry at al for the debugMessagesFile.

 

I was able to stop the logs entirley from writing by removing the process.statusOutputDirectory entirley from the process-config.

 

Thanks for your help.

 

This was selected as the best answer