+ Start a Discussion
joshQjoshQ 

Support Ending for Weak Versions of SSL / Impact on PHP code?

Hi!

Any impact on PHP?

Support Ending for Weak Versions of SSL

PHP versions 4-5 with Salesforce API 5-8?

joshQjoshQ
Anyway to test this before Sunday?
dapkusdapkus
PHP uses OpenSSL for it's SSL.  OpenSSL supports TLSv1/SSLv3 and it supports strong ciphers.    You shouldn't have any problems.


joshQjoshQ
THX!
dapkusdapkus
you can test things by trying invocations against our Sandbox edition -- Sandbox has had weak SSL disabled since December.  

You can try it even if you don't have a Sandbox account --  try the login() method with bogus username/password.  If you get a "INVALID LOGIN" fault, then you have successfully negotiated an SSL connection and passed SOAP messages.  

the endpoint for sandbox login is:

https://test.salesforce.com/

-Pete