+ Start a Discussion
needdevhelpneeddevhelp 

Oh Forever more... Now it won't login.

I'm using ASP classic to connect to salesforce.
 
Here's the code:
set sfApi = Server.CreateObject("SForceOfficeToolkit3.SForceSession3.1")
 result = sfApi.login(username,password)
 response.write result & "<br/>"
 response.write "Error = " &  sfApi.errormessage & "<br/>"
 
Here's the output:
false
Unable to send request to server. The requested lookup key was not found in any active activation context.
 
I'm positive that the username/password is correct.  I found a post that suggested permissions issues with this error so I tried correcting that but with no result.
 
any ideas?
foghornfoghorn

We have seen this error before (if you google that exact phrase you’ll get a lot of info)

Internally we are still looking for the exact cause of this, but some things you can try (and if one works could you post back?)

Check the account IIS is running under.   It should be the normal IIS user account. (IIS manager properties of the web server, Directory Securtiy)

Try running IIS as a normal admin user.

Try regsvr32 on the sf_msapi.dll as an admin (program files\salesforce.com).

 This type of error generally means the process does not have correct access to the object or one of its dependencies.

 

margotqmargotq
I'm running into the same error.  Did you ever find a solution for this?
BXBX

I am having the same problems.  Running Windows Server 2003 Service Pack 1.

I tried regsvr32 the dll.  Still no luck.  :0(

foghornfoghorn

Had a little time to debug this (mostly spent setting it up)

 

So far I’ve found that it IS something specific to the IIS user.  Running IIS as a normal user doesn’t have a problem.

foghornfoghorn

The problem ended up being with the auto proxy discovery code.  The IIS user gets an access denied message when it queries the connection for any pre-configured proxy settings (which makes sense as it’s not a “real” user).  Sadly the real error message is suppressed.

 

I have it working correctly in v 4 of the toolkit and if we do another release of v 3 (not likely but it could happen) I’ll back port the fix.

BXBX

Any idea when v4 or a back fix to v3 will happen? I need to know if I should wait for this fix or try a different language.

 

Thanks in advance

foghornfoghorn

Looks like we are going to rev v 3 to support a feature for one of our products.

 

It should be generally available within a month or so.

 

If you’d like, I can send you a build to test that includes the fix

 

Chopkins@salesforce.com

Peter UchytilPeter Uchytil
So is this the only fix for using the Office Toolkit on Server 2003? I have spent the day trying to get various versions of the API working and for one reason or another everything is failing. Classic ASP is what I know the best so I was really hoping this would work.

If the only way to get it to work is to use your fix, would you mind sending it to me? I'd really appreciate it. Thanks!

Pete
peter_uchytil@kentrox.com
bhayhowbhayhow

I've been struggling with this problem since January, and I've reported it to Salesforce support and the discussion boards, without finding a resolution.

Your post from May 17, 2006 indicates that the solution should be available within a month or so.  It's now two months after - is the solution available yet?  Would you be so kind as to send me the installation files so that I can give it a try?

Thank you so much for your help.

Bill Hayhow
Direct Knowledge
bill@directk.com
248.478.9965

bhayhowbhayhow
Here's some addtional information. 
 
I have two computers, both running XP-Pro, and Office Edition was working on one of them and not on the other ('The requested lookup key was not found...').
 
I looked at the IIS configuration and both were running IIS as the default user, but on the working computer, 'anonymous access' was turned off. 
 
When I turned off 'anonymous access' on the other computer, I no longer received the error, and Office Edition worked just fine.
 
Perhaps this will provide some clues as to what the problem is, and what the solution might be. 
 
I still need to use Office Edition with 'anonymous access' turned on, so any solutions would be most appreciated.
 
Thanks,
 
Bill Hayhow
Direct Knowledge, LLC
248.478.9965
scdavidscdavid
I have been having the same problem. I turned off anonymous access on IIS and that fixed it.
mshelmanmshelman

This thread is now almost a year old. Still no solution?

Mike