+ Start a Discussion
Mike_M_2Mike_M_2 

Email To Case Sandbox invalid recipient

I am trying to use Email to Case in my sandbox. I started by doing a complete refresh of our development sandbox. All of the Email to Case Routing Addresses were successfully copied to the new sandbox. However, as expected, the "Email Service Address"s were not copied. So I regenerated a couple of the Service Addresses. Still no problem. Then I clicked on one of the service addresses, and as expected, it popped open a Microsoft Outlook New Email window with the "To" address pre-populated. Then I filled in a Subject: line and typed in a few Body: lines and clicked on "Send". It went perfectly, a new Case was created in Salesforce. So, I tried sending another Email to the exact same "Service Address". This time it FAILED. Instead, I got a bounced email back to my Outlook Inbox. I repeated the experiment multiple times, each time getting a bounced email. I tried sending the Email to Case from my Gmail account; same result, bounced email.

 

Screen Snap of Bounced Email 

 

I tried the same thing again using some other newly generated sandbox Service Addresses. Same thing. The first attempt to send Email to Case succeded, but sending to the same address again failed. That was Thursday, but now, I can't even get a single success even with trying a freshly generated Service Address. Very frustrated. Thanks for any help.

Mike

 

tonyrabbittonyrabbit

I am having the same problem (though mine fails consistently) when trying to send to a newly created email Service in a sandbox.

Mike_M_2Mike_M_2

The strange thing for me is it all works perfectly fine in production.
This makes testing in sandbox almost impossible because a manually entered case behaves differently than an Email to Case since Salesforce doesn't perform system validation on Email to Case.  See: http://www.salesforce.com/us/developer/docs/apexcode/Content/apex_triggers_order_of_execution.htm