+ Start a Discussion
deepak_tintrideepak_tintri 

Report Scheduling BUG- User/Public group dropdown is not shown on the schedule report page

When I tried to schedule a report today in our production instance, User/Public group dropdown is getting displayed  on the schedule report page.

find button is also not working. I do not get any results. 

 

Schedule Report  


    Running User
 
 
            Email Report
To me   To me and/or others...
     
Search Public Groups for:  
 
Select From
--None--
Add
 
 
Remove
Send Email To
  --None--
    Schedule Report
Frequency Daily
Weekly
Monthly
Every weekday
Every day 
*Start
 
10/2/2013 ]
*End
 
10/2/2013 ]
Preferred Start Time

Exact start time will depend on job queue activity.
    Save Changes Save report modifications with this schedule
 

Discard report modifications

 

Anybody experienced same issue before.

Sonam_SFDCSonam_SFDC

Hi Deepak,

 

Could you please check it again and let me know the behavior of Schedule Report section now or was it intermittent?


If the issue persists, inbox me your ORG ID, username and grant login access so i can investigate the issue further..

deepak_tintrideepak_tintri
It worked after adding new public group in sharing for the report folder. That report folder was accessible to "All Internal Users" public group so it should have shown "Public Group/Users" drop down.
Jodi Nemser-AbrahamsJodi Nemser-Abrahams
Hi, 

Having this issue too.  I have a folder that is accessible to all users.  The user dropdown menu is not showing up when I go to schedule the reports.  It was working days ago... not sure what's going on.

No drop-down
Garen MorenoGaren Moreno
Hi Jodi, 
Did they ever get back to you with a solution? I am having the same exact problem. Folder is accessible to all users yet the dropdown menu does not appear. 
Thank you, 
Garen

Jodi Nemser-AbrahamsJodi Nemser-Abrahams
I was using Chrome.  Someone suggested using Firefox, and that made the difference for me.  I'm not sure what changed, because I had been able to schedule reports from Chrome until very recently.


Girish RGirish R
This issue exists since a long time & Salesforce is incapable of resolving the bug till this date. Even for my instance I am unable to schedule reports in spite of adding the suitable permissions to public group on the reporting folder. On Google Chrome the 2nd radio button "To Me and/or others “never works. On my developer account I get 3 dropdowns a) to choose public group b) Role & subordinates c) Users . But the find button in spite of giving the correct user/public group name the find button does not yield any result. The situation is even more bad in the unlimited edition, in my client's instance hosted on CS1 server only public group dropdown is visible & find button does not work at all.
I am unable to raise a case from my production org & redirected to developer forum where Salesforce support staff never pays any attention.
Girish RGirish R
The solution is as follows:
1) Provide report folder level permissions to the concerned user or roles or a public group .
2) Use any other browser apart from Chrome.  ( https://success.salesforce.com/issues_view?id=a1p30000000T40WAAS )
3) The dropdowns become active & then choose the range for scheduling.

VOte for this idea too :  https://success.salesforce.com/ideaView?id=08730000000kzD5AAI

Nirmal Shah 6Nirmal Shah 6

The Best Answer, I have face this problem today itself. And got the idea.

"Unschedule existing schedules, and than try one more time to schedule your new report".
you will be able to schedule report.
thnx..

Kelley MinorKelley Minor
My report folder is available to my users, I've tried using IE and Chrome, and I've tried unscheduling and rescheduling.  I have the option to add users, but then I can't find any users!  I had one single user on the report before I unscheduled it, and when I tried to reschedule, she has vanished.  Any fixes???
Kelley MinorKelley Minor
Found my answer elsewhere.  Nirmal, I unscheduled and tried to reschedule -- I could then select ZERO recipients!  I had to open my report folder up to EVERYONE, schedule and add the recipients I was previously trying to add, and then change my report folder sharing back to only the public groups that it was shared to originally. My recipients were members of those public groups but weren't options in my recipient box.