+ Start a Discussion
doug at sid dot orgdoug at sid dot org 

force.com IDE crashes on startup if Eclipse is installed

Hi all,

 

So, for much of the last 72 hours I've been installing, uninstalling, and reinstalling Force.com IDE and Eclipse, using different versions etc., to try to get Force IDE to work and connect to the servers so I can upload some code, and apex class, that works in my sandbox to production.  

 

However, the Force IDE crashes whenever Eclipse of most any version (tried three so far) is installed, and it won't seem to work by itself without Eclipse.  When it crashes, on startup, Force IDE gives the following error message window, titled just "Force IDE:" :  (  Thus I can't get my code out of the sandbox to production

"

JVM terminated. Exit code=-1
-Dfile.encoding=UTF-8
-Xms256m
-Xmx1024m
-XX:PermSize=126M
-XX:maxPermSize=512
-Djava.class.path=C:\Users\Doug\AppData\local\salesforce.com\Force.com IDE
2\../Common/plugins/org.eclipse.equinox.launcher_1.0.200.v.20090520.jar
-os win32
-ws win32
-arch x86
-showsplash
-launcher C:\Users\Doug\AppData\Local\salesforce.com\Force.com IDE
2\forceide.exe
-Name Forceide
--launcher.library C:\Users\Doug\AppData\local\salesforce.com\Force.com IDE
2\../Common/plugins/org.eclipse.equinox.launcher_1.0.200.v.20090520.jar
-Xms40m
-Xmx256m
-install C:\Users\Doug\AppData\Local\salesforce.com\Force.com IDE 2
-configuration C:\Users\Doug\AppData\Local\salesforce.com\Force.com IDE
2\configuration
-vm C:\Program Files\Java\jre7\bin\client\jvm.dll
-vmargs
-Dfile.encoding=UTF-8
-Xms256m
-Xmx1024m
-XX:PermSize=128M
-XX:MaxPermSize=512M
-Djava.class.path=C:\Users\Doug\AppData\Local\salesforce.com\Force.com IDE
2\../Common/plugins/org.eclipse.equinox.launcher_1.0.200.v.20090520.jar

"

Does anyone have any idea how I can get around this error?  (I'm on a Windows 7 laptop with up to date virus protection, if that matters...)

 

Thanks!

 

Suresh RaghuramSuresh Raghuram

do you have andy proxy server make sure to set up the proxy settings. in eclipse.

 

check with os weather you are using 32 bit or 64 bit bit and download as of your settings.

doug at sid dot orgdoug at sid dot org

Thanks Suree,

I confirmed I am on a 32 bit computer/32 bit Windows, and am using 32 bit versions of the software.

I'm not using a proxy server..and have tried this at home and the office to no avail.

I keep looking through blogs trying to find someone with similar problem, but only see one entry from back in 2010 so far, and that solution didn't work.

Thanks again, hope to solve this issue....

Pedro Da GreatPedro Da Great

What was the install directory that you used? Is it "C:\Users\Doug\AppData\local\salesforce.com\Force.com IDE" 

 

Let's try putting it on the root of c:\ if you can (to rule out any security issues with that directory). It should not matter but install it in a directory without spaces. Again that should not matter but I always do this to avoid any classpath issues (old habit).

 

When you launch it, make sure to right click and launch as admin. Let us know how that goes.