+ Start a Discussion
ia-ryania-ryan 

Can't log in to Force.com IDE v 20.0

I've been doing all my development straight in the browser. Tonight I decided to try out the Force.com IDE when I got tired of the rich text box that is about half the height of my monitor.

 

I downloaded the version on the website, which is 20.0 and went to create a project. It keeps giving me an error that something is wrong with my username, password, or security token. I reset my token and tried again, to no avail. Looking at the logs in the browser it says I'm failing due to an invalid password. I know this isn't true because I logged inusing the same password to check the security logs. 

 

I've tried closing it and restarting the IDE and I already mentioned getting a new security token.

 

Any other ideas on how I can actually use this thing?

Best Answer chosen by Admin (Salesforce Developers) 
ia-ryania-ryan

So the answer to this is you are actually NOT supposed to prepend your password to the security token. 

 

This is frustrating because it's the way SFDC always tells you to use it but they must be doing it themselves in this case. When I entered my security token without the password added to the front it worked fine.

 

It's also frustrating that the error they were giving for this was "Invalid Password" (in the Login History) rather than something to do with the security token.

All Answers

LakshmanLakshman

Check the HostName in the environment. If you are using production login then no need to provide HostName and if you are using Sandbox then it should be set to "Other" and the HostName should be test.salesforce.com.

I would recommend you to use Eclipse IDE 3.x.x instead of Force.com IDE and install the Force.com plugin in it. More details can be found by clicking here .If you are planning to use eclipse IDE then do this setting before downloading the plugin :

 

Window->Preferences->General->Network Connections then in that scree you will see Active Providers, set it to Manual and then Apply Ok and install the plugin.

 

Regards,

Lakshman

ia-ryania-ryan

I had played around with the host names previously, again without any luck. I even tried Other and setting it directly to the host that I have when I log in (na12.salesforce.com). I am using  a test org created through partnerforce that was created as a SalesCloud org I believe. I would think the hostname is right since I can see the login attempts under manage users (still has Invalid Password). That would make me believe it's getting to the right place, just having issues when it gets there.

 

I uninstalled the Force.com IDE and installed Eclipse v 3.6.1 and the Force.com plugin per your instructions, but I get the same error.

LakshmanLakshman

Are you appending security token at the end of password? If no please do it.

You can get Security token from:  My Personal Information->Reset My Security Token-> and then click Rese Security Token button. You will recieve the token on your registered email address and then you can use it as I mentioned above.

 

Let me know if it is still not working.

Host Name for test org/Sandbox should be Other-> test.salesforce.com

 

Regards,

Lakshman

ia-ryania-ryan

Yes, I am prepending my password to the security token. I decided to make sure I was doing it right and logged in to  Force.com Explorer (the SOQL explorer tool) using the same credentials for the same org. This worked just fine.

 

When trying to log in with Eclipse the Login Type - Status - Application under Login History shows:

 

Partner Product - Invalid Password - Apex Plugin

 

When using Force.com Explorer it shows

 

Other Apex API - Success - N/A

 

Force.com Explorer doesn't require a password, only a username and security token (which is still the Password+Security Token). It does have an Environment dropdown like Eclipse - I logged in with it set to 'Production or Developer Edition'.

ia-ryania-ryan

So the answer to this is you are actually NOT supposed to prepend your password to the security token. 

 

This is frustrating because it's the way SFDC always tells you to use it but they must be doing it themselves in this case. When I entered my security token without the password added to the front it worked fine.

 

It's also frustrating that the error they were giving for this was "Invalid Password" (in the Login History) rather than something to do with the security token.

This was selected as the best answer
LakshmanLakshman

Yes actually there is a separate row for adding security token and password when you are using Eclipse IDE plugin. So you must add password in Password row and Security token in Security token row. Eclipse internally concatenates it and sends to SF.

So there is no need to prepend password to security token in Eclipse the need to be added separately in the respective rows.

 

Regards,

Lakshman