+ Start a Discussion
PengoPengo 

Production vs. Test Environment differences

Hi,
I'm using php_sforce_nusoap to retrieve Product information from SalesForce and load these into a local DB.
I have done multiple tests to retrieve data from production environment, the test have performed as expected. The end point in these cases is set as "https://www.salesforce.com/services/Soap/u/5.0" and is defined in partner.wsdl

Today, I tried to switch to a test environment where I modified the current endpoint to "https://test.salesforce.com/services/Soap/u/5.0"
My client can log in fine, but exactly the same query as in production environment does not return any results. I even tried the query with sforce explorer and was able to get the expected results, so obviously nothing is wrong with the query. The communication between Salesforce and my client seems to be fine, the only problem is that the result returned is always empty.
Anyone know what is going on?

Thanks.
rchoi21rchoi21
the test instance isn't guaranteed to have the same data. your org was probably copied a while ago and either data was deleted in the test instance by somebody else in your org, or the sharing model/access levels have changed for the same user on the test instance.

I'd suggest trying a number of things:

1.) verify that the org has same (or valid) data on both instances
2.) verify the following are identical on both instances for the same user:
a.) user role
b.) user profile
c.) sharing rules
3.) verify that the user on the test instance owns data of the type you're querying

tell us what you find.