+ Start a Discussion
joshQjoshQ 

PHP Notice: SoapClient::__doRequest(): Unable to find the wrapper "https"

Hi there,
I just did a new install of php 5.1.2 and the php5-1.0.3 sforce package (on Win XP). I even read the instructions :) I believe I set up php correctly (php.ini, extensions and copies the openSSL dll / php in path etc.)... But this is what I get:
> php HelloWorld.php
PHP Notice:  SoapClient::__doRequest(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in c:\Program Files\Apache Group\Apache2\htdocs\sforce-php\soapclient\SforceBaseClient.php on line 74
SSL support is not available in this build


I surfed the web and this site... but I couldn’t fine anything.
I saw the pointer about the fopen and I have allow_url_fopen = On

Any ideas? I hope I missed something trivial... or a toggle somewhere.
I need an extra pair of eyes on this,
THX



Tran ManTran Man
Create a file, paste the following in, save the file, and load it into your browser. 

Code:
<?php

phpinfo();

?>

 


You should be presented with an output of your php configuration. Make sure that SSL is enabled.  If not, you need to enable it.  See the php.html that is included with the example.


joshQ wrote:

Hi there,
I just did a new install of php 5.1.2 and the php5-1.0.3 sforce package (on Win XP). I even read the instructions :) I believe I set up php correctly (php.ini, extensions and copies the openSSL dll / php in path etc.)... But this is what I get:
> php HelloWorld.php
PHP Notice:  SoapClient::__doRequest(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in c:\Program Files\Apache Group\Apache2\htdocs\sforce-php\soapclient\SforceBaseClient.php on line 74
SSL support is not available in this build


I surfed the web and this site... but I couldn’t fine anything.
I saw the pointer about the fopen and I have allow_url_fopen = On

Any ideas? I hope I missed something trivial... or a toggle somewhere.
I need an extra pair of eyes on this,
THX






Message Edited by Tran Man on 04-07-2006 02:38 PM

joshQjoshQ
Tran,
I did the php_info printout, curl is enabled w/openSSL support. I also compared the printout w/a Unix box we have running PHP 4 and the old sForce client... looks OK.

As mentioned in my first post - I did read and followed the instructions... that's why I'm baffled... I can't see what I missed. Therefore the request for help.
Phip
PP
pH
pp
HP
Edit...
Ignore all
Add to dictionary
opens
openest
openness
openly
openers
Edit...
Ignore all
Add to dictionary
support
sport
spurt
sporty
Supt
Edit...
Revert to "suport"
force
forces
source
farce
suffice
Edit...
Ignore all
Add to dictionary
OK
OJ
oak
oik
KO
Edit...
Revert to "ok"
Tran ManTran Man


joshQ wrote:
Tran,
I did the php_info printout, curl is enabled w/openSSL support. I also compared the printout w/a Unix box we have running PHP 4 and the old sForce client... looks OK.

As mentioned in my first post - I did read and followed the instructions... that's why I'm baffled... I can't see what I missed. Therefore the request for help.
Phip
PP
pH
pp
HP
Edit...
Ignore all
Add to dictionary
opens
openest
openness
openly
openers
Edit...
Ignore all
Add to dictionary
support
sport
spurt
sporty
Supt
Edit...
Revert to "suport"
force
forces
source
farce
suffice
Edit...
Ignore all
Add to dictionary
OK
OJ
oak
oik
KO
Edit...
Revert to "ok"


I disabled php_openssl.dll and restarted Apache and was able to get the same error.

Can you post your CURL Information from phpinfo?  I can also take a look at you php.ini if you e-mail it to me:  ntran@salesforce.com
joshQjoshQ
OK - Thx Tran for your help --- I got it working now.
All - This was a case of multiple php.ini files, one in the php install base (was in the path and was used by php) and another in the system32, which was edited but… not used :(

All I needed to do was to synch the files and restart apache – and I was done.

 

Thx Tram for being my 2nd pair of eyes on this.