+ Start a Discussion

Omniauth and Force.com - multi_json versions

I'm attempting to follow the article linked here for integrating with Salesforce: https://devcenter.heroku.com/articles/omniauth-and-force-com


When I reach the step to run "rails generate controller sessions create", I'm getting an error for multi_json.


"Bundler could not find compatible versions for gem "multi_json": 
In Gemfile: rails (=3.2.3) x86-mingw32 depends on multi_json (~> 1.0) x86-mingw32 
omniauth (=0.2.0) x86-mingw32 depends on multi_json (0.0.5)"


Has anyone else encountered this?

Software Allies TeamSoftware Allies Team

Try checking your gemfile to make sure that gem "multi_json" is added. If it is, try running a bundle update/install to see if that resolves any dependency issues.




Jorge Valdivia

Software Allies



Thanks for the reply.  Unfortunately, I'm getting the same error if I include the line in the Gemfile or not.