+ Start a Discussion
TLFTLF 

Anyone seeing problems with uninstallation of apps getting stuck in the "pending" state?

Today, I tried uninstalling a trial version of an app that I got off of AppExchange. The uninstallation appears to have gotten stuck in the "pending" state. I noticed this same behavior in two other Salesforce instances with a different app yesterday. In those cases, the uninstall has now been in the pending state for about 18 hours. Is it normal for an uninstall to take this long? Has anyone else seen this?
ckempckemp
Yup... I'm trying to uninstall two apps on my Sandbox, and it's been stuck in "pending" for the last 24 hours.  I need them to clear out so I can continue on with testing my new app (you can't upgrade until it's removed), so this really screws me.  How long does this process typically take?
TLFTLF
Likewise ckemp. In two of the three cases in which I've seen this, we were in the middle of QA testing an application. We were trying to uninstall an old version so we can install a newer version and continue testing. We're basically dead in the water until we can resolve this. We submitted cases with SF on this, but thus far no response. If I hear anything I will post here.
ckempckemp
Ditto with QA.  I deleted with the intention of it deleting immediately (I don't think it indicated otherwise until the deletion was going through) so we're in the same boat. :-(

Thanks for keeping me updated, TLF!  Will do the same on my end...
richardc_rsvprichardc_rsvp
We have seen uninstall pending as well, for 24 hours so far. I wonder if anyone at the Appexchange is aware of this. We opened a case on another installation issue and have not heard back in a few days.
ckempckemp
The uninstall of my packages reached the expiry date, so now the uninstalls have been cancelled.  Strange stuff, but at least it isn't hanging around in the "Pending" state forever!
TLFTLF
Same thing happened for me. I tried uninstalling again and got in the same state (pending). Called support today after not getting any response to the cases that I opened Friday from Help | My Cases | Log a Case. They are investigating.
TLFTLF
So this is the response I got from Salesforce on my uninstallation problems:

Notes on Uninstalling Apps

* If you are uninstalling an app that includes a custom object, all components on that custom object are also deleted. This includes custom fields, validation rules, s-controls, custom buttons and links, as well as workflow rules and approval processes.
* You cannot uninstall an app whenever any component in the app is referenced by a component that will not get included in the uninstall. For example:
o When an installed app includes any component on a standard object that another component references, Salesforce prevents you from uninstalling the app. This means that you can install an app that includes a custom user field and build a workflow rule that gets triggered when the value of that field is a specific value. Uninstalling the app would prevent your workflow from working.
o When you have installed two unrelated apps that each include a custom object and one custom object component references a component in the other, Salesforce prevents you from uninstalling the app. This means that you can install an expense report app that includes a custom user field and create a validation rule on another installed custom object that references that custom user field. However, uninstalling the expense report app would prevent the validation rule from working.
o When an installed folder contains components you added after installation, Salesforce prevents you from uninstalling the app.
o When an installed letterhead is used for an email template you added after installation, Salesforce prevents you from uninstalling the app.
* Uninstall export files contain custom app data for your package, excluding some components such as documents and formula field values.
This is verbatim out of the help documentation. I'm trying to figure out what dependencies might be blocking my uninstall. In one case, the package has created some custom field definitions on the standard object types (Contact, Account, etc.). So, maybe I can't uninstall because I have instances of these objects. I tried exporting and then deleting these object instances to see if I can eliminate the dependency. I have to wait for my pending uninstall to expire before I can try it again.
ckempckemp
Crap!  That might be the case for me as well.  I installed a managed and unmanaged version of the same app and there might be some references from the unmanaged to the managed because of namespaces.  It sure would be nice if the uninstaller fired off an e-mail indicating what the problem is instead of silently failing.  I guess I'll try and manually remove everything and try again (what a pain!)

Thanks for keeping me updated, TLF.  Will let you know if this works for me.
A_SmithA_Smith
Hi All,

We're aware of the issue related to uninstall.  We have a fix in the works that should be released by tonight.  Please try uninstalling the package again tonight.  Note:  It may take up to 48 hours for your packages marked as "Pending" to be reset so you can attempt the uninstall again.  If you're still having issues tomorrow, please let me know via this post and we'll investigate further.

Thanks for your patience and my apologies for the trouble. 

Thanks,
Andrew
TLFTLF
Uninstall succeeded for me this morning. :smileyhappy: Thanks!
ckempckemp
Ditto!  Still having problems uninstalling my managed package (see this thread) but the unmanaged one disappeared last night.

Thanks Salesforce!!
blakelyblakely

I know these posts were back from 2008, but I have been having the same issue since Spring '12.

 

Here is my post: http://boards.developerforce.com/t5/AppExchange-Directory-Packaging/Installed-packages-will-not-uninstall-no-error-message/m-p/399931

 

Wondering if this issue has returned, or if I need to be looking at a reference in my code that is preventing the app from uninstalling with no error message.