+ Start a Discussion
Jonathan 2Jonathan 2 

Package Install Error

Hi

 

We are trying to move our source code to a new developer account and have created a unmanaged package to do so. The package errors out on installation in the new account and only provide this error code. 577855813-15223 (717204042)

 

Can you please explain where I can lookup this error code and how to fix it?

 

Kind Regards

 

BulentBulent

if the target org doesn't have sites then you will need to use a managed package.

Does the target org have sites? 

SFNEWDEVSFNEWDEV

Thanks for your reply.

 

We are trying to transfer from one dev org to another and both have them did not have sites.

 

I enabled sites into the target org and the install did not fail immediately this time, I got an email stating that the install failed with this error code: Error Number: 577855813-18976 (717204042)
 

Regards

Sharper128Sharper128

I am having the same issue and have been for a couple of days.  I tried once again to install an unmanaged package from a DE to another DE.  The error is:

 

Your requested install failed. Please try this again.

None of the data or setup information in your Salesforce organization should have been affected by this error.

If this error persists, contact Salesforce Support through your normal channels and reference number: 1737951265-419 (-599792421)

 

When this first happened on Tuesday I started reading the boards.  I have deleted and erased any deleted fields and custom objects.  I depreciated and deleted any other package in the DE.  I created a new package, and uploaded.  Upload was successful.  As a package that has never been managed, there are no name space issues.  I opened a case through the partner Portal: Case #02535259

 

However, my case was closed and I got this email:

 

Dear Steven,

Thank you for contacting Salesforce.com Support. Your case number is 02535259. Please refer to this number when discussing this issue with our representatives.

Unfortunately Due to the issue involving A custom application I cannot assist you in this case. Please refer to http://developer.force.com/
Thanks again,
So.... Any suggestion?  I have run out of ideas. 
Jonathan 2Jonathan 2

@ Sharper128

 

I have noticed that if any apex code contains the namespace prefix before the custom objects (eg. abc__customObject), the unmanaged package transfer fails. So you could try checking all triggers and apex classes and remove the namespace prefix from all custom objects references as it is not required.

 

Another thing to try would be to isolate the cause of the error, so you could try a package with some basic objects, try if it works and then keep adding more to it till you can pinpoint what the error is. It sounds a bit cumbersome but if all fails its worth a try.

 

Good Luck.

GoForceGoGoForceGo

I am having a similar issue. Case # 02541475

 

 

I have a base package and I am trying to install an unmanaged package as an extension package. Obviously the extension package Apex code and triggers use the base package prefix when referencing base package objects.


Any help appreciated.

 

 

=================================================================
Your requested install failed. Please try this again.

None of the data or setup information in your Salesforce organization should have been affected by this error.

If this error persists, contact Salesforce Support through your normal channels and reference number: 749622665-488 (-1897878611)