+ Start a Discussion
DSLDSL 

Why does my VF Page have a feature dependency?

I opened a case for this one but it seems like partner portal cases are just a black hole. Anyone have a better place for package/appexchange cases? Maybe old-fashioned email?

 

This one really screams of a bug but maybe someone here has an idea. We released a managed package that worked in all editions, even PE. We then started building and linked in the Campaign object. We were about to publish but DID NOT when we saw the campaign in there. (won't work in PE) 

 

So we unwound all of the code and made a custom object to use instead of campaign. This all worked great except for one piece. For some reason Campaign is still required. It is included in a dependency on our VF page. Not the controller, the actual VF page.

 

Now how a VF page could ever require a Campaign feature is beyond me. I know it USED to reference campaign objects the controller. But those were removed and relinked to a custom object. But it seems like something in the dependency checker did not "re-check" correctly. A VF page can't require any feature as far as I know since it only references the custom controller or static resources (CSS/JS).

 

Any thoughts on where to go? I have several PE customers waiting to buy and one that already bought!

 

Thanks!

shillyershillyer

Hmmm...I think you may have discovered a bug. I created a Visualforce page with Campaign as the standard controller. If you click on the Show Dependencies button, it explains that Campaign is a Feature Dependency. Makes sense so far. Change the standard controller of that page to Account, it still shows Campaigns as a Feature Dependency.

 

Not sure how much work this is for you, but if you create a new page and move the exact same code over, does the dependency disappear? It did for me, that may be your best workaround.

 

Hope that helps,

Sati

DSLDSL

My old page is my main landing page for the app which has already been released many times. I tried even blanking out the page, but didn't try switching to a std controller for Contact or something else. So let's give it a shot:

 

1) Change page to be <apex:page>blah blah</apex:page>.  Still required campaign.

2) Change page to: <apex:page standardcontroller="Account">blah blah</apex:page> still required.

 

Great idea though. It clearly has nothing to do with what's on the page itself since I can erase the whole thing and still have the requirement. It's buried somewhere in the cloud.

 

I had enough other EE and UE customers waiting that I did have to release it with the campaign feature requirement in there while we figure out the PE part.

 

Any ideas of how to get this bug filed, and more importantly, how to get it my DE fixed so I don't have to start all over and can help my PE customers?

 

Thanks!

shillyershillyer

Post your case number here and we'll escalate through support to determine what's going on.

 

Best,

Sat

DSLDSL

In the PRM portal it's 02539153. We opened it yesterday but never got the auto-email reply like we used to on the normal app exchange support. We're just anxious to get this looked at since we have customers waiting and one already purchased.

 

Thank you very much!

 

 

DSLDSL

Hi Sat,

 

Any update or other support roads to try? We have not heard a thing back and we are losing business because of this bug.

 

Thanks!

dsl

shillyershillyer

Support is currently investigating, you should be contacted by the end of today.

 

Best,

Sati