+ Start a Discussion
Perfectionist52Perfectionist52 

Managed Released Package install Error "Data not available"

Hi,

When installing a managed released package from my developer org. into my production account i am getting following error: 

Data Not Available
    
The data you were trying to access could not be found. It may be due to 
another user deleting the data or a system error. If you know the data is not deleted but cannot access it, please look at our support page.

I am unable to understand what is causing it as the current version is 11.7 and i have already installed number of previous versions. The case number of this issue from my production account is "03177422". It has been 24 hours or so i have not recieved any response from salesforce yet. I also tried to call salesforce support but it was of no use. Please help me is this is very urgent and the package contains urgent changes to running application.
 
P.S. I have tried to contact salesforce support on email, through case and by phone as well but no response. POOR SUPPORT I MUST SAY. 
 
Regards,

Matt
shillyershillyer

I've escalated your case, you should hear back soon. If not, please contact me offline at shillyer@salesforce.com

 

Best,

Sati

Perfectionist52Perfectionist52

Hi Shillyer, 

 

Thanks a lot. Took late holidays because of the problem. Anyways, i haven't heard from salesforce yet. Now can you please help me out in this or just let me know about the possible causes for this error.  

 

The problem is I am creating package from developer org. and migrating it first to sandbox and then after testing I migrate same package created in developer org. to live. Last package version that was successfully installed was 11.2. After that I am unable to install any package created in developer to sandbox or live.  

 

I experimented with a new developer account and got installed there without any problems. I also tried few more versions of package to install on developer org. and none caused any problem. Considering all this can you please advise which portions of code or org. settings I should look out for. 

 

Thanks and Regards,

 

Matt.

Message Edited by Perfectionist52 on 12-29-2009 09:32 PM
Perfectionist52Perfectionist52
By making some changes in code including class and vf pages, i don't know which one worked as i had many updates and regard it as a bug from salesforce, i am able to get rid of that data unavailable error but getting this error now: 

AppExchange Package Unavailable 
Your package is not currently available. Recently uploaded packages may take up to 30 minutes to be available across allsalesforce.com instances. Please wait 30 minutes and try your package installation again. 

It has been few hours since i am trying. following is the url of package i am trying to install: 

https://login.salesforce.com/?startURL=%2Fpackaging%2FinstallPackage.apexp%3Fp0%3D04t80000000jKEG 

I had tried to install this on sandbox and another developer account and it worked. Help me out as i am getting more and more frustrated with the problems like these and quality of support salesforce guys are providing. 

Regards, 

Matt.