+ Start a Discussion
atomaratomar 

spring 10 is out but we still dont see any option to package Standard Action Overrides.

 So spring 10 is out but we still don't see any option to package standard action overrides.

 

The partner developer org that we are using to create our managed package is on na7 and i do see AnswersNew! and Translation WorkbenchNew!

 

We even created a new package this morning, just to check if the standard action overrides are being packaged implicitly.

 

Still no luck.

 

Do i need to raise a case in partner portal or am i missing something obvious?

 

 

aalbertaalbert

Are you trying to package a custom object that has Action Overrides? This new feature only works with Custom Objects. 

 

atomaratomar

Yes. Custom objects only.

 

 Do you see some kind of option under packaging?

 

Thanks.  

Message Edited by atomar on 02-08-2010 02:01 PM
aalbertaalbert

It is implicitly included. I have an Action Override configured on my custom object. The override is pointing to a Visualforce page. When I create the package, as long as the custom object is included, the Visualforce page associated to the standard action override is also included in my package.

 

Then when the package is installed, the installing-org admin can configure that override on the custom object. 

 

 

atomaratomar

 

Oh. ..so are you saying that after installing the package - admin is still required to configure the override on the custom object?

 

I thought the whole point of being able to package the standard action overrides was to save my customers from the misery of configuring my app. If they still have to follow my 12 step help, what did we achieve with this release? 

 

 

 

aalbertaalbert

On install, the action override is pre-configured as it was in the packaging org. The admin can modify that setting if they want to, but the action override persists on install.

 

 

atomaratomar

 

Thanks aalbert.

 

So in our case, when we created a new managed package this morning and installed in our test org, we lost the action overrides even though we have them configured in the packaging org.

 

I guess i will try it one more time.

 

 

 

 

 

aalbertaalbert

Is the test org where you installed the package upgraded to Spring '10? I moved an unmanaged package between two Spring '10 orgs and the action override persisted on the custom object upon install. It should work as you want...

atomaratomar

I think so. I can see AnswersNew!  and Translation WorkbenchNew!.  in both orgs.

 

I am using 2 partner developer orgs - got them sometime in October/November 2009. 

 

Just tried one more time..still no luck.

 

 

atomaratomar

I just installed unmanaged version of my app to the same test org and action overrides persisted upon install..but i lose them when i install managed version of my app to the same test org.

 

something is up with my managed packaging org or how salesforce handles standard action override with managed packages.

aalbertaalbert

Interesting. I was able to successfully install action overrides in both a managed and unmanaged package.

is the action override a visualforce page? Is that page in the package? Does it get installed in the installing org? And its just not associated to the action override? 

atomaratomar

yes, action override is a VF page. Yes the page is in the managed package. Yes the page gets installed in the test org (managed and unmanaged install) and it is just associated to the action override.

 

aalbertaalbert
i believe you need to upload a new version of your package to leverage this new Spring '10 functionality. Have you tried that with your managed package?
atomaratomar

Hi aalbert

 

Good morning.

 

Yes, I have. Tried with a new version of managed beta and managed release.

 

I am almost out of ideas and test cases. 

A_SmithA_Smith

There is an issue in the Spring '10 release where standard action overrides created prior to the release may not be packageable.  We'll be resolving this issue for all customers by Feb. 19th.  After that date, you'll need to reupload your package and then the overrides will be installed.  We're sorry for the inconvenience.

 

Best, 

gv007gv007

Andrew,

             I have similar type of issue in a package in that I want override custom objects using a Visual force page ,when am trying to install am getting an message please contact salesforce,after going to this thread I did a beta managed package and have the same issue.

 

 283471091-839(error message ref number)

 

Message Edited by gv007 on 02-12-2010 11:32 AM
ciccic
Are you installing the managed package from new or updating an existing install?  Prehaps the overrides only work in a new install since in an upgrade they may have been changed by the customer.
gv007gv007
Any update on override issue.
A_SmithA_Smith
Should be fixed tomorrow.
Keith654Keith654

Using the Force IDE against a https://prerelna1.pre.salesforce.com/ instance, I don't see any meta data corresponding to my override of the "View" "Standard Buttons and Links" for two of my custom objects. What should I see in the meta data?

 

When I deploy using the sf:deploy from ant-salesforce.jar the overrides are not present.

Message Edited by Keith654 on 03-01-2010 10:51 AM
cgosscgoss

We're seeing the same issue with a package created on 3/7. We have some VF overrides on a new custom object, and after installing the upgrade package, do not see the overrides in the subscriber org.

 

The object was not previously in the subscriber org, but the object was first packaged before Sp10.

 

Any ideas?

ca_peterson_oldca_peterson_old

Seeing this issue with a package made in april too, already filed a case with partner support, waiting to hear back....