+ Start a Discussion
bob_buzzardbob_buzzard 

Managed Package Upgrade Error

Is anyone else having problems upgrading managed packages at the moment?

 

I've just completed a fairly large chunk of changes to our managed packages and have successfully uploaded to the App Exchange.  We have trialfore set up for our package, so I've created a new trial and attempted to upgrade the managed package to the latest version, which fails with an error similar to the following each time:

 

Error Number: 1663381573-11307 (983782282)

 

The first two parts of the error number change each time I attempt the upgrade, but the bracketed number (presumably the actual error code) stays the same.

 

I've then installed the trial version of the package into a brand new dev org and hit the same problem when upgrading, same bracketed error message too.

 

As I had made a large number of changes, I uninstalled everything from my dev org and went back to an earlier version of the package, and then attempted to upgrade to the next in sequence, which had very few changes and has worked in the past, but the same error code.  Once again, I can install the entire package into an empty dev org fine, but I don't appear to be able to upgrade under any circumstances.

 

I've been banging my head against this for the last 18 hours or thereabouts, so if anyone has any tips or tricks I'd be very keen to hear.

Ispita_NavatarIspita_Navatar

No , I am not facing any issues but at times unexplainable errors are encountered for which one gets the weird messages which are  more ambiguous than helpful.

The best way out for you will be to create a support case with salesforce, this seems to be an org-specific and package specific issue.

 

Hope this helps.

Chris JohnChris John

Were you able to escalate this to SFDC support yet?

 

Let me know if this is still an issue for you and I'll chase it up.

 

Thanks,

 

Chris