+ Start a Discussion
Esp-MPEsp-MP 

Not able to create managed package in Dev Org

 

Hi, I am trying to create a managed package in a Dev Org but the problem is as soon as I create the managed package and compile all the classes in the org, i get the below error. Surprisingly when I comment these lines also, i get the same error . Looks like it is being picked from cache.

line 39, column 24: quotefieldset is not a fieldSet of Quote
line -1, column -1: Previous load of class failed: Espresso_MP.cloneQuoteController: line 39, column 24: quotefieldset is not a fieldSet of Quote
line -1, column -1: Previous load of class failed: Espresso_MP.cloneQuoteController: line 39, column 24: quotefieldset is not a fieldSet of Quote
line -1, column -1: Previous load of class failed: Espresso_MP.cloneQuoteController: line 39, column 24: quotefieldset is not a fieldSet of Quote
line -1, column -1: Previous load of class failed: Espresso_MP.cloneQuoteController: line 39, column 24: quotefieldset is not a fieldSet of Quote

This field set is part of the managed package. So not sure what is the issue here ? I see this issue everywhere where field sets are used. We need to create the managed package and deliver it to the testing team ASAP so that it can be delivered to the client. Any help would be highly appreciated. Below are the Org details.

Org Id : 00Db0000000XxKP
Instance : eu2

Important Note : I have tried deploying all the code in 3 different Dev orgs and everywhere I got the same error.\

 

 

-Vik

Devendra@SFDCDevendra@SFDC

Hi,

 

I am not quite sure what might be causing this. But can you please check the version of VF and Apex class. It is because FieldSet components are available in API version 21.0 and later.

 

 

Esp-MPEsp-MP

Hi Devendra,

 

The api version is 24 that is why I was able to use fieldsets in the code. The issue is that since the namespace is added to everything in the code, those classes which are using fieldsets are throwing this error. I am not able to edit and save those classes again. 

 

-V

Devendra@SFDCDevendra@SFDC

Please make sure you have added those fieldsets in managed package.

Esp-MPEsp-MP

Those fieldsets are added in the managed package since the namespace is added to fieldsets as well along with the classes.