+ Start a Discussion
gopikagopika 

Error while installing managed package

Hi

I got the following error while installing managed package

 

Your requested install failed. Please try this again.

None of the data or setup information in your salesforce.com organization should have been affected by this error.

If this error persists, contact salesforce.com Support through your normal channels and reference number: 1801800798-17943 (-2087640787)

While searching through the community, the problem may occur due to the presence of permission set in the managed package. But in my case permission set is not at all present in the package. Kindly provide any idea regarding this.

ReidCReidC

Based on the error, it looks to me like the package is expecting RecordTypes, but the org you are installing them into doesn't have them activated,.  Checkout the ISV Force Guide for details on this kind of thing. 

http://na9.salesforce.com/help/doc/en/salesforce_packaging_guide.pdf

DarrellDDarrellD

At the same time you may want to open a ticket with the error number for Salesforce while you investigate the other comments. Unfortunately the managed package errors have not gotten to the point where they are at all useful to the users. The first error of this kind we got, we spent a couple days trying to research the issue. When we finally did submit a ticket we discovered that it was a "bug" related to Static Resources that had to go up to the R&D team to resolve. Then then rolled back our manged packages so we could install again.

 

So we wasted a bunch of time trying to troubleshoot something we never could have resolved on our own.

- Darrell