+ Start a Discussion
arasuarasu 

Defect in Apex Email Services in production?

Hi,
 
We are using apex email services. I was able to add the apex generated emailid  as the replyto address in sandbox and it works fine. But when I try the same in production, it fails with following error:

INVALID_EMAIL_ADDRESS, Invalid replyTo address
 
Appreciate if you could kindly throw some light on this. I am unable to understand why it works in sandbox and NOT in production. Is there some other configuration missing? We need to set the from or reply to  or cc address to apex generated emaild ID when sending email from within salesforce, but currently none of these are working in production(but works in sandbox)
 
Thanks and regards,
Ambili
Rasmus MenckeRasmus Mencke
You can not use an inbound email service address as the reply-to address. We are working on relaxing this restriction.
arasuarasu

Hi Rasmus,

Thanks for your response.

But then why does salesforce allow development in the sandbox using this feature i.e. allowing the replyTo to be set to the apex generated emailID? As I mentioned before this is working perfectly fine in sandbox. We had this feature implemented for an important business requirement and today to our surprise we are being told that it is NOT supported in production.

I think if a specific feature is not supported in production, then it should not be supported even in sandbox just to be consistent.

Regards,
Ambili



Message Edited by arasu on 08-13-2008 04:39 PM
Rasmus MenckeRasmus Mencke
That is actually a bug in sandbox, it is not supposed to work in Sandbox. I am working on getting the restriction remove in production to allow you to set the reply-to address as an inbound email address. I currently don't have an ETA on when we can complete this.
arasuarasu
Hi Rasmus,

Do you have any update on this issue or do you know if this issue is fixed in production in winter 09 release?
 
Issue: In production when user clicks the "Reply" or "Reply All" button, the salesforce.com generated email ID from Apex Email services is not auto-populated in the "To" email address field.
 
Thanks and regards,
Ambili