+ Start a Discussion
MKPartners.comMKPartners.com 

Deploying Apex Failed due to lack of coverage of sfLma.updatePackages

I'm deploying some apex from a DE org to Production using Eclipse.  The Production org has Salesforce's License Manager App installed and the deployment is failing because one of the Triggers in that App "sfLma.updatePackages" does not have enough test coverage.

Since its a managed package I don't have access to the app to see the code and try to write my own test coverage.  I don't think that uninstalling the App is really an option since data would be lost.

Has anyone else seen this?  I don't think this was a problem with the older eclipse toolkit.  Any suggestions?

Thanks in advance.

-Matt
Ron HessRon Hess
Matt, can you file a support case for this issue, it appears to be a catch-22 and we would have to dive into the issue in some detail.

Thanks for reporting this.
Ron WildRon Wild
I'm having the same problem (working from the Sandbox generated from the ISV version of Salesforce), and would love to see the solution posted here.

I tried 'deselect all' in the deployment plan and then selecting the triggers/methods I wanted to deploy - hoping that I could leave the sfLma.updatePackages trigger, but that didn't work.

Thanks,


Matt PanningMatt Panning
Hi,

ISV version is a 2 user version of Salesforce that is provisioned to partners for the purpose of tracking leads from AppExchange, and should not be the basis for development.  Can you develop in a DE org or the Test Edition (a 20 user DE org with additional storage provisioned under the same agreement) instead? 

Thanks

Matt
Ron WildRon Wild
The ISV version, though limited to 2 users, is a production account, and comes with a Sandbox for development.  Although, just to be clear, I'm not developing an appexchange application here, just adding to the functionality of my ISV account. 

However, the real issue appears to with the license management app.  I need to add a trigger to the License object, so whether I'm in a sandbox or in a dev account, the LMA has to be installed there.   And with the LMA failing the validation step I can't publish from any dev environment.





Message Edited by Ron Wild on 03-13-2008 10:43 PM
Ron HessRon Hess
It sounds like the version of the LMA that comes with the ISV edition pre-dates the code coverage requirement and since this is managed cannot be fixed, only updated. 

I don't see any way to make modifications if the LMA is failing the current testing requirement, is it possible to upgrade the LMA installed there?

What functionality are you adding to your ISV account?

Can you open a case so that we can track down the underlying issue with the LMA app, and why it does not have proper test coverage in the ISV edition.  Unless i'm missing something that is the underlying problem.

Ron WildRon Wild
I have v 1.0.1 of the LMA installed, which appears to be the latest release.

I've added a custom field to store the email address of the Lead associated with the License record when it's installed.  The trigger simply copies the Lead's email to this field after insert, so I can set up a workflow rule to autogenerate a 'Welcome' email when a license goes to 'Active' status.

I've also submitted a case as you requested.




Message Edited by Ron Wild on 03-14-2008 08:37 AM
Ron WildRon Wild
I tried deploying a simple custom object definition from a clean developer edition account and ran into the same roadblock.   Apparently it's impossible to deploy to an account with the LMA installed.