+ Start a Discussion
KruviKruvi 

Validation Errors While Saving Record(s)

Hi All

 

I'm trying to add a field of type Formula to a custom object and I'm getting the following error when I hit 'save' at the end of the new field wizard:

 



Validation Errors While Saving Record(s)

There were custom validation error(s) encountered while saving the affected record(s). The first validation error encountered was "Formula has no columnType". 

 

I can't find doumentation of this error.

Please does anyone know what does this error mean and what can be the cause of it?

 

Mant thanks

 

 

SteveMo__cSteveMo__c

Can you post a screenshot of the Field setup, Formula, and error?

KruviKruvi

Here are couple of attachements

 

 

 

Mant thanks

 

SteveMo__cSteveMo__c

Those imagaes are tiny, I cannot read anything to help you.  Can you post a larger screenshot or upload it to a hosted site like GoogleDocs, or Picasa?  

SteveMo__cSteveMo__c

are any of the fields in your formula Roll-Up Summary fields?

KruviKruvi

Yes

SteveMo__cSteveMo__c

I think that might be what is causing the problem, you might have to log a Case with SFDC Support.

John BrothertonJohn Brotherton
I was able to workaround this by changing the formula type from checkbox (boolean) to Text and using "Yes" or "No" values in my IF statement. Not the best workaround but it solved what I needed. Fields referenced are not roll up summaries
Prasad KasotePrasad Kasote
I tried re-creating the formula field from scratch and it worked for me
Hrishikesh Kolhe 3Hrishikesh Kolhe 3
i am getting same error while creating formula field how to solve also images are not available in above solution can you help me on this..................................
 
Hrishikesh Kolhe 3Hrishikesh Kolhe 3

@Kruvi google 404 error