+ Start a Discussion
monty808808monty808808 

When will eclipse galileo be suppoted for the IDE?

Hi,

 

When will eclipse galileo be suppoted for the IDE?

 

Thanks

AliasJMacAliasJMac

I just downloaded Galileo and attempted to install the Force.com IDE with no luck.  I received the error message below.  Odd thing is that my installation states the org.eclipse.ui is version 3.5.0...

 

 

Cannot complete the install because one or more required items could not be found.

  Software being installed: Force.com IDE 16.0.0.200906151227 (com.salesforce.ide.feature.feature.group 16.0.0.200906151227)

  Missing requirement: Force.com IDE 16.0.0.200906151227 (com.salesforce.ide 16.0.0.200906151227) requires 'bundle org.eclipse.ui [3.3.0,3.5.0)' but it could not be found

  Cannot satisfy dependency:

    From: Force.com IDE 16.0.0.200906151227 (com.salesforce.ide.feature.feature.group 16.0.0.200906151227)

    To: com.salesforce.ide [16.0.0.200906151227] 

WPCMSWPCMS

I just posted the same error asking what is going on.

 

There is a note on this web page http://wiki.developerforce.com/index.php/Force.com_IDE#Installation

that

"Note: The Force.com IDE is not supported on Eclipse 3.5."

 

How do we go about fixing this? I downloaded Eclipse RCP/Plug-in for Developers. I don't even know if this is the right one.

deeproxdeeprox
Did you ever find a fix for this?
GanjehGanjeh
What's the target release date for Eclipse 3.5 support?  Is there a beta I can sign-up for?
Curry-ManCurry-Man
I opened a case with salesforce support for this, and was basically told tough luck.  I had to uninstall and reinstall an older version of eclipse, wich broke with a recent update for Ubuntu.  If anyone's found a workaround it would be greatly appreciated, as I would like to continue using Salesforce and linux together.
Curry-ManCurry-Man
Based on the error messages that I get when trying to install, it looks like there are some jar files that force.com is looking for that either have been removed with the upgrade, or are the incorrect version.   Does anyone else see this as the case?
Curry-ManCurry-Man

to fix the ubuntu upgrade issue I removed all versions of java from the machine and reinstalled it, which seemed to fix the issue.   Not exactly sure what caused the issue.

 

I'll try my theory on replacing some of the galileo files with those from ganymede to see if it works.  I found that, at least on my system, I can run 2 versions of eclipse with no problem, so I can at least use ganymede until a fix or a workaround is found.