+ Start a Discussion
NikhilNikhil 

EmailService not working in Production.

Hi Folks,

 

I am trying to transfer some data from one Salesforce org to another Salesforce Org by using EmailService.

 

So to achive this I created a EmailService in X-Org(Production)

-Generated one EmailID  for this EmailService,Marked the EmailService and EmailID as ACTIVE

-While creating EmailService i left the "Accept Email From" text Box as blank ,then i generated the EmailD there is again a text Box as "Accept Email From" in this i specified the my Email as njain@astadia.com,beause the user from which i am logging into the Y-Org(Production) has njain@astadia.com as Email

 

From the Y-Org(Production) I am posting a email through Apex code to this newly generated EmailID

 

The whole thing is working in Sandbox perfectly fine.

 

But this is not working in Production.

Then i tried dropping a email to the EmailService EmailID from my outlook(njain@astadia.com).

Now the Emailservice is catching the mail and processing it as well.

 

But when i am dropping email from Apex code of Y-Org(Production) its not catching the mail

 

Can anyone please suggest anything for this.

 

Already tested

EmailService as well as Email Generated are Active and are catching email from outlook(from authenticated EmailId )

From  X-Org(Production) email is posted with no Error

 

I tried dropping the mail to myself as well and i found in the from part it is showing no-reply@salesforce.com on behalf of njain@astadia.com,so i kept "no-reply@salesforce.com" in "Accept Email From"  text box and then tried but still not working

 

Please help

 

Thanks

Nikhil

NikhilNikhil

Just got this as well...

 

"This message was created automatically by the mail system.

A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:
 

catchinkemail@19jjld8znijjndbgnsaaggqlp.in.salesforce.com
(Undelivered): 554 null "

 

Usually, the "reason: 554 mail server permanently rejected message" email is received because the mail server thought your email is spam.

 

So does this means this means that when we are trying to drop email to this kind of emailID from salesforce apex code the server assumes this is a spam mail

 

Please Help !!!

Message Edited by Nikhil on 06-04-2009 07:08 AM
NikhilNikhil

So just to update you...

 

This was a bug of salesforce.com and they recrified it few days back

 

Actualy when we were trying to drop email from 1 salesforce org to another salesforce org's email service

SF servers were treating this mail id as a spam

 

Thanks

 

 

Rasmus MenckeRasmus Mencke

This looks to me like a issue where the subject line was blank and we where not able to process the email and hand it over to Apex. For a few email clients (MUA) we have seen the subject: header missing and since we where expecting it, it caused an exception.

 

We do not spam check the emails and reject them based on that. We have other internal mechanisms in place to prevent that.