+ Start a Discussion
MarceldeBMarceldeB 

apex error messages

Hi,

I recently installed a new development environment. in my other environment I get an email with error details when there is a runtime error (developer script exception), but in the new environment I do not get these messages. Probably I miss a setting here, but I cannot find it.

I did set the 'send apex mails' checkbox in my userdetails.

any tips?

Ispita_NavatarIspita_Navatar

The setting you have mentioned should have delivered you the error emails. You try this:-If you have created a package in the Package details there is an option "Apex Exception Notification Recipient"  please do set it too to see if you start getting your emails.

Also check your email client if you have not marked as spam mails from salesforce.

 

Did this answer your question? If not, let me know what didn't work, or if so, please mark it solved.

MarceldeBMarceldeB

Hi, thanks for your response. I did create a package (which contains no items) and my user is included in the field you mention.

The only real difference in this area with the previous environment is that I created a prefix.

Ispita_NavatarIspita_Navatar

Are you getting other mails from your org, say when you "Send an email" via "Log a Call"  functionality to your email address. Adding the namespace prefix should not cause emails to get blocked.

MarceldeBMarceldeB

Yes, this works fine, I just sent a mail as you described, which I received. I also tried the email delivery check from 34 ip adresses and i received the 34 mails...

MarceldeBMarceldeB

Problem had to do with error messages in an org with naming prefix for custom objects activated from objects which are not part of a package are indeed not send. Appeared to be solved in summer 10 release!