+ Start a Discussion
joshQjoshQ 

Help w/the eclipse toolkit

I've been using Eclipse for awhile to dev sControls and a whole lot of other stuff (php, perl, javascript...).
Yesterday I got access to Apex on my Dev account and was ready to get started...
1) upgrades eclipse to 3.2.1
2) java 1.5-08
3) installed the apex toolkit

 but now... neither AppExchange Toolkit nor the Apex Toolkit

all issues loading classes.

What give? Or what did I do wrong :smileyhappy: and how do I fix it?

Tran ManTran Man
What error are you getting?
joshQjoshQ
ok - so when I try to open "old" stuff (AppExchange) I get:
Unable to create this part due to an internal error. Reason for the failure: The editor class could not be instantiated. This usually indicates that the editor's class name was mistyped in plugin.xml.
When I try to create a new trigger (New/Other/Apex), I get:
Plug-in com.appexchange.toolkit was unable to load class com.appexchange.plugin.wizard.ApexTriggerWizard.
This happens with all types (project, package control).

btw, via "manage configuration" in eclipse I can revert back to AppExchange 1.0.2206... successfully.
CRMfusion - GWCRMfusion - GW
Josh;
 
I had a similar error but I think it was due to my upgrade to Vista.  To solve the problem I re-downloaded the latest version of eclipse, installed it to a different directory, installed the APEX plugin and then ran an update from the help menu.
 
I also changed my workspace and reloaded the project from my sfdc info.
 
GlennW
joshQjoshQ
Thx - I'll try this...
joshQjoshQ
try it - same issue!
Anyone?
joshQjoshQ
Apex Eclipse Toolkit (8.0.1015) requires plug-in "org.apache.axis".

Any idea where to get this mising part? Found the Axis2-1.1 zip file out there... but no org.apache.axis file
DevAngelDevAngel
There is a step by step tutorial on installing eclipse and the toolkit here.

https://wiki.apexdevnet.com/index.php/Apex_Toolkit_for_Eclipse

Axis is installed with the Web and J2EE Development features.
MarkerVMarkerV
I just can't get this to work.  I've followed the install directions:

https://wiki.apexdevnet.com/index.php/Apex_Toolkit_for_Eclipse

I read that the Apex plugin is not compatible with 3.2, so I downloaded 3.1.  I had to import the Callisto Discovery Site for the software updates, but I'm getting the erro that it can't find the plug-in "org.apache.axis".

How do I get that?

I'm all confused...
Tran ManTran Man
Where are you seeing that it is not compatible with 3.2?  Per the wiki, the eclipse plugin supports only 3.2.1 and up.
MarkerVMarkerV
I'm getting hung up around 50% when I try to do the software updates on 3.2:
http://community.salesforce.com/sforce/board/message?board.id=JAVA_development&message.id=3238

On 3.1 I can't even get that far.
Tran ManTran Man
I've experienced something similar if I chose a particular mirror for downloading Calisto.  If it just hangs, I would go back and select a different mirror.
MarkerVMarkerV
That seemed to be it.  Odd, I had tried a couple different mirrors and they stalled around 53% each time.  Finally one worked.  Thanks...At least I got it installed, now to deal with anything else (scared by other problems I've read) that comes up...
Tran ManTran Man
Great!  Would you mind updating the Wiki page with your findings?