+ Start a Discussion
Peter_Peter_ 

IDE - Can't "upgrade project"

I'm getting a warning on a project in the IDE:

 

"Project was created in an older version of the Force.com IDE and must be upgraded to be used with Winter '11.  You will not be able to save or refresh files in this project from the server until you upgrade it.  To upgrade, use the upgrade wizard by right-clicking on the project in Package Explorer and choosing Force.com > Upgrade Project. " 

 

1) I've update Eclipse(helios)  to latest Force.com IDE release

2) Right clicking on project does NOT give an option to "upgrade project"

3) Despite the warning,  i am able to save and refresh files from the server

4) I've tried closing project, restarting eclipse and then re-opening project.

 

How do i upgrade this project?

 

Peter

dmchengdmcheng

Usually the upgrade message window has buttons along the bottom to allow you perform the upgrade.  You're not seeing those buttons?

Peter_Peter_

sorry i'm not understanding - what/which upgrade message window?

my project has a trainagle withan an exclamation point, right clicking on this does not give me an option to upgrade project.

BTW project WAS built with the first release of Winter 11 IDE, so i'm not sure why i'm getting this anyway.

Peter 

dmchengdmcheng

In the past, when I upgrade the IDE, the first time I clicked on a project, I was prompted to upgrade the project with Yes and No buttons (or perhaps Cancel, I can't remember).  If I said No, then I had to exit the IDE and restart it in order to see the prompt again.  But I always got the prompt until I upgraded the project.

 

However, when I upgraded to Helios recently I created a new workspace instead of using my current one, in case I had to go back to Galileo.  So I have not been upgrading my previous projects, just downloading, and perhaps the prompt is different now or there is a bug.

 

I've never done a right-click upgrade - always done it through the prompt.

Peter_Peter_

i vaguely recall seeing that window now and thinking...i'll do that later :) .

 

Eclipse  restarts don't seem to help.

 

Peter

 

 

WizradWizrad

Right click your project in eclipse.

 

Force.com -> Update/grade Project

Peter_Peter_

Nope - The choice is not there

 

The icon with exclamation is on the project BUT when i right click project -> Force.com there are NO options to update/upgrade project.

 

Peter

dmchengdmcheng

I'm stumped.  Have you tried uninstall Helios and reinstalling?  Or make a copy of your workspace and do File -> Switch Workspace and see if you get upgrade prompts in the new workspace.

Peter_Peter_

trying to avoid that.

 

Other than the warning and the icon this "problem" does NOT seem to affect being able to save/refresh files to server .

 

At this point i'm thinking,  if it isn'tr really badly broken then don't try and  "fix -it" .

 

Peter

Lime CatLime Cat

I'm experiencing the same issue...using Helios with the latest Force.com IDE.  I get the warning message for my project but I do not have the option to upgrade it like the message states.

 

Has anyone figured out how to resolve this yet?

SHaTROSHaTRO

I was getting the same error with Helios and latest Force.com IDE after renaming my project.  I just deleted my project and imported the Org data again and the error went away.  I suspect this is a bug in the IDE.

goabhigogoabhigo

Did anyone found solution for this?

AndyRouseAndyRouse

I've just upgraded to 23.0 and found that I had to do an extra step.

 

I had to go into the IDE Help menu and select "Check for Updates" after having followed the updates for the Force.com IDE instructions. the Eclipse "Check for Updates" option also found the Force.com update and I just selected everything that needed updating.

 

Once I did that, the usual "Upgrade project" options became available.

 

Andy

Nathan HincheyNathan Hinchey
I am having this same problem 7 years later. Are there any solutions?
Devin Jacob 5Devin Jacob 5
Same issue. 8 years after the initial report. 
Devin Jacob 5Devin Jacob 5
An additional wrinkle, I checked for IDE updates and found there are none available. I then recreated my project and still see the message. I suspect this message is meaningless since it doesn't actually appear to prevent syncing to the server.