+ Start a Discussion
bracekevbracekev 

Force IDE Connection Issues behind Firewall

Hi, 


I recently installed Force IDE and am experiencing some frustrating issues around connectivity behind our corporate firewall. I have read the other posts and ensured that my proxy settings are correct. I have tried Force IDE on a Mac running Lion and on a Windows machine. I have also installed Eclipse and the Force plug-in on both the Mac and the Windows machine and none of the configurations work behind the firewall. Again, my proxy settings are correct. I have the Preferences->Network Connections Active Provider set to Manual and I have a Host and port defined for HTTP and HTTPS.

 

When I create a New Force Project, All the resources come down fine behind the firewall. I see all my classes, etc. Its when I go to make a change (I make a simple string change) and save it, I get 2 exceptions, a BuilderException (Unable to perform save on all files)  and a RetrieveException (Unable to perform conflict check). When I try to refresh from the server, the basic message I get is: "Unable to refresh resource xzy. Connection Refused." The stack traces in the logs are all java connection issues. I am running with java 1.6.  I was not able to pull anything out in the stack trace that would point me to the direction of a fix. 


I try the same exact changes at home, outside the firewall, and all is fine. Change gets saved and I am good to go. So, behind the Firewall, does not work, at home, works fine. I have compared my proxy settings with a co worker and they are exactly the same and his machine works fine.


An insight as to what might be causing this issue would be greatly appreciated!

 

Kevin

kiranmutturukiranmutturu

you need to install micerosft firewall client ...this will bypass your proxy....

bracekevbracekev

Hi Thanks for your reply. Appreciate it.  I would like to try to solve this without having to bypass the corporate proxy.  As I mention in my summary, I have a co worker that is not by passing the proxy and all works fine. I would also prefer to run on my Mac, not a windows machine.

 

Any other ideas that could help me pinpoint the real issue?

 

Thanks! 

ElcalvoMikeElcalvoMike

Is is possible you are on a different wan vs your coworker.

Make sure all WAN IPs are white listed in your org.

bracekevbracekev

Hi, Good idea. I did White lIst the IPs, but still having the same issue.

 

Also, just to clarify, When I create a new project in Force, it is successful in polling the server for the Objects it needs to bring down. Its the "Save"/"Refresh from server" events that that are failing. Not sure how the internals work, but the fact that it was able to connect and do the initial pull of Objects would make me think that the White list is not the issue. 

 

Any other ideas? Any help would be greatly appreciated.

 

Kevin

pbackenpbacken

Having the same issue.  Proxy setings are correct as I can hit other resources.

 

ANybody else seeing similar problems or have a solution?

bracekevbracekev

Hi, 

 

I don't want this topic to Die....

 

I was wondering if there is anything I need to do in the Salesforce settings to allow my Force IDE to connect to it to refresh Objects or push new ones up from behind the Proxy (it works at home..)? Any security settings that need to be set? 

 

Please....ugently need some help. It is still not worrking....

 

Thanks

ElcalvoMikeElcalvoMike

could it be related to a desktop policy. Are you running symantec, windows firewall etc?

You said it was working on anothers computer but not yours. Seems a likely culprit.

bracekevbracekev

Great Suggestion. I actually shut down all the McAFee services running on my standard desktop image this morning and still had no luck. The only reason why I didn't do this earlier is that I also have a MacBook with me that is not running the company's standard image (it only runs Sophos and no firewall (.... until I get this resolved.))  and that too is giving me the same issues behind the corporate firewall.  

 

I did install tcpmon (I'm not a network guru) this morning and, even though the communication is encrypted, I did see a lot of initial chatter about "Pulse" and a "certificate". Can't be sure that this is my issue though. I see in the Config ini that the pulse server URL is www.poweredbypulse.com:443 and in the same ini there is a Client.credentials parameter. Not sure how this gets in here. Maybe the pulse credentials are bad? I did notice in the standard Force IDE logs that it appears to try to hit this URL first. Maybe this is where it is failing? The stack trace really doesn't tell me much other than there was a refused connection...might be the pulse connection? 

 

Is there any way to increase the logging so that I get more verbose messages?

 

Thanks again for everyone's help...I do appreciate it!