+ Start a Discussion
NicolaiNicolai 

Labs "Inline Account Hierarchy" requires update access on Accounts

We are using the Inline Account Hierarchy from Force.com labs (http://appexchange.salesforce.com/listingDetail?listingId=a0N300000016chCEAQ) but it requires update rights on the account table to work - otherwise the message ""Content cannot be displayed: Update access denied for Account"" is shown in place of the VF page part.

I've looked in the various Apex code but not been able to find out where it is it tries to update the account object, and if it either can be avoided, or solved using field level security.

Anyone got any hints? Thanks.

 

Br

Nicolai

NicolaiNicolai

Did a full debug of a pageview, as you can see below there is no update statements, so I assume this can not be solved? :(

 

09:21:53.231|LIMIT_USAGE_FOR_NS|(default)|

Number of SOQL queries: 9 out of 100

Number of query rows: 9 out of 50000

Number of SOSL queries: 0 out of 20

Number of DML statements: 0 out of 150

Number of DML rows: 0 out of 10000

Number of script statements: 352 out of 200000

Maximum heap size: 0 out of 6000000

Number of callouts: 0 out of 10

Number of Email Invocations: 0 out of 10

Number of fields describes: 0 out of 100

Number of record type describes: 0 out of 100

Number of child relationships describes: 0 out of 100

Number of picklist describes: 0 out of 100

Number of future calls: 0 out of 10

Aaron EngelAaron Engel

We had the same issue and found that removing the reference to the inline account hierarchy component and putting all of the component code in the page, fixed the isssue.