+ Start a Discussion
plapla 

Save error: Unable to perform save on all files: No match found

Hello,

 

I got the following error message when trying to save a test class into production. 

 

Save error: Unable to perform save on all files: No match found

 

This test class UpdateOppWithQuoteDetailsTest works in QA sandbox but not in production. I'm not sure what caused this error. Below is a portion of the test class. Please help. Thanks

 

Paul

 

private class UpdateOppWithQuoteDetailsTest

{

/*

Parameter(s): NA

Return Type : NA

Reason : Upon changing the Status of the Quote to “Complete”.

Change the stage of the Opportunity to “CM RFP Shipped” or "RFP Shipped"

and populate RFP/Rates Sent field information from the Quote

on theOpportunity record for 'Renewal' record type.

*/

statictestMethodvoidopptoquoteTest()

{

Profile p = [select id from profile where name='Client Management'];

 

User u = newUser(alias = 'sg', email='sharanya.g89@cognizant.com',

CommunityNickname =

'sharanya.g88',LastName='sg',

LocaleSidKey=

'en_US', LanguageLocaleKey='en_US', timezonesidkey='America/Los_Angeles',

emailencodingkey=

'UTF-8',profileid = p.Id, username='sharanya99@gmail.com');

List<

RecordType> accrtypes = [SelectName, Id FromRecordTypewhere sObjectType='Account'and isActive=true];

System.runAs(u)

{

Map<String,String> accountRecordTypes =

newMap<String,String>{};

 

Anup JadhavAnup Jadhav

You might want to consider re-writing your test class to use dummy data rather than relying on the data created in the environments.

 

- A

plapla

Thanks for you input. I've tried to disable this test class but it says the associated test class failed to execute. So how can I bypass this problem? I basically want to disable this test class so to avoid running to this issue. The error displays this message "Save error: Unable to perform save on all files: No match found" but does not show what lines it encounters the problem. I cannot deploy my other items without fixing this error. Any ideas will be appreciated.

 

Thanks

Paul