+ Start a Discussion
yvk431yvk431 

Invalid field CurrencyIsoCode for SObject OpportunityTeamMember

Hi,

 

I am sirprised to see this error on my visual force page which is used to customize the Sales Team functionality. The same was working fine for last few months . There was no reference to the currencyIsoCode both in page/controller as well. I guess this has some thing to do with the recent updated to the Sales Team object. But I am unable to find out the exact issue. Did any one came across or knew about this. Please help me out.

 

 

--yvk

Best Answer chosen by Admin (Salesforce Developers) 
yvk431yvk431

Got it, just need to update the vfp version to the recent one. Thanks

 

--yvk

All Answers

yvk431yvk431

the issue is with user reference, when i comment the user part its working fine. i didnt get what is wrong with it.

<table >
              <tr>             
                <td><b>User</b></td>
                <td></td>
                <td><b>Opportunity Access</b></td>
                <td></td>
                <td><b>Team Role</b></td>
              </tr>        
              
              <apex:repeat value="{!LstSalesTeam}" var="ST" >
                  <tr>                   
                    <td><apex:inputField value="{!ST.oppTM.UserId}" required="false"/></td>
                    <td></td>
                    <td><apex:selectList value="{!ST.roleAcc}" size="1">
                                <apex:selectOptions value="{!AccLevels}"/>                       
                        </apex:selectList>
                    </td>
                    <td></td>
                    <td>
                      
                        <apex:selectList value="{!ST.STMember}" size="1" >
                                <apex:selectOptions value="{!OptionsTM}" />                       
                        </apex:selectList>
                    </td>

                  </tr>                 
              </apex:repeat>
          </table>

 LstSalesTeam is a wrapper class so as to accomodate separate team roles and access levels.

 

--yvk

 

yvk431yvk431

Got it, just need to update the vfp version to the recent one. Thanks

 

--yvk

This was selected as the best answer
JIDzenpriseJIDzenprise

Figured this out. On a VF email template you have to go to "Edit Template" then "Version Settings"