+ Start a Discussion
Chris NortonChris Norton 

Compile error in hidden module: OTWrap

One of our sales guys is getting the following error when he opens Word documents:
 
   "Compile error in hidden module: OTWrap"
 
Win XP SP2
Office 2003

Any ideas? He only has Offline and Outlook Edition installed.

Best Answer chosen by Admin (Salesforce Developers) 
JPSeaburyJPSeabury
Solution:
 
With all Microsoft applications (Word, Excel, etc.) closed, locate and delete the SFDC.xla file.  This file is usually located in:
 

C:\Program Files\Microsoft Office\Office\Xlstart    or

C:\Program Files\Microsoft Office\Office12\Xlstart    or

C:\Documents and Settings\Username\Application Data\Microsoft\Excel\XLSTART

 

If you are unable to find the file, use file search from your MS-Windows "Start" button. 
 
Credit / Kudos to the Tech Support Guy.


Message Edited by JPSeabury on 08-28-2008 01:57 PM

All Answers

InterLegis360InterLegis360

I know this is a little late for a reply, but I had the same problem in Excel 2007.  I was getting several pop-up boxes when I opened Excel that said "Microsoft Forms: Could not load some objects because they are not available on this machine", then a final pop-up that said "Microsoft VB: Compile error in hidden module: OTWrap".

I realized that I had uninstalled salesforce for office and that there might be a connection between them.  A quick reinstall and the problem went away.

I'd like to see salesforce come up with a cleaner uninstall, but until then, this worked for me.

Hope this helps,

Matt

JPSeaburyJPSeabury
Solution:
 
With all Microsoft applications (Word, Excel, etc.) closed, locate and delete the SFDC.xla file.  This file is usually located in:
 

C:\Program Files\Microsoft Office\Office\Xlstart    or

C:\Program Files\Microsoft Office\Office12\Xlstart    or

C:\Documents and Settings\Username\Application Data\Microsoft\Excel\XLSTART

 

If you are unable to find the file, use file search from your MS-Windows "Start" button. 
 
Credit / Kudos to the Tech Support Guy.


Message Edited by JPSeabury on 08-28-2008 01:57 PM
This was selected as the best answer
Staylor17Staylor17
Thanks this really helped deleting the xlfa file worked!
 
 
Finally im done with the nag screen everytime i open excel or word...
 
 
BlairBlair

This was very helpful for Excel, but it did not work for Word. 

 

I then went into work and click on help and went to knowledgebaseand typed in OTWRAP Click to see the results that worked.

http://support.microsoft.com/kb/312595

 

or

To resolve this issue, remove Universal Translator 2000 from the XLStart folder, and then delete Ut2000.dot. To do this, follow these steps:

  1. Start Windows Explorer.
  2. Browse to C:\Program Files\Microsoft Office\Office\XLStart.
  3. Right-click UT2000, and then press DELETE.

    When you receive the message that asks you to confirm the deletion, click Yes.
  4. Click Start, point to Find, and then click Files or Folders.
  5. In the Named box, type ut2000.dot, and then click Find Now.
  6. Press SHIFT, click each Ut2000.dot file, and then press DELETE.

    When you receive the message that asks you to confirm the deletion, click Yes.

 

 

 

BlairBlair

This was very helpful for Excel, but it did not work for Word. 

 

I then went into MS WORD and clicked on help and went to knowledgebaseand typed in OTWRAP - Click to see the results that worked.

http://support.microsoft.com/kb/312595

 

or

 

To resolve this issue, remove Universal Translator 2000 from the XLStart folder, and then delete Ut2000.dot. To do this, follow these steps:

  1. Start Windows Explorer.
  2. Browse to C:\Program Files\Microsoft Office\Office\XLStart.
  3. Right-click UT2000, and then press DELETE.

    When you receive the message that asks you to confirm the deletion, click Yes.
  4. Click Start, point to Find, and then click Files or Folders.
  5. In the Named box, type ut2000.dot, and then click Find Now.
  6. Press SHIFT, click each Ut2000.dot file, and then press DELETE.

    When you receive the message that asks you to confirm the deletion, click Yes.
JakerJaker

Thanks that did the job.

JMaribbay

Chris HighChris High

You, sir or madam, rock. Thank you for the straightforward working tip.

NawafNawaf

Solved!!

 

Thanks a zillion!!

BobBBobB

I thank you as well.

 

...Bob

Scott WomackScott Womack

Yes thanks a bunch

 

SalesMercenariesSalesMercenaries

Thank you!

 

"Compile error in hidden module: OTWrap" is gone from Excel.

 

SFDC doesn't seem to work as well as it once did with Microsoft Office. Having trouble with the plug-in to Outlook? Mine becomes automatically disabled with the error "unstable" associated with it. The whole Microsoft Office 2010 desktop integration with SFDC hasn't been very productive so it's been completely uninstalled.

 

mduncan@centricsitmduncan@centricsit

Worked perfectly for me!