+ Start a Discussion
PeanutmanPeanutman 

Constantly being prompted for SFDC username/password

Hi All,

 

This problem started after the Spring Release.

 

The user successfully logs into Salesforce.com via Outlook without a problem. Then, the user will be navigating around in Salesforce.com and click on a link.

 

A new window opens up telling them they have been logged out of Salesforce.com and prompts them to put in their username/password. After they do so, it continues to tell them it is invalid.

 

It can't be an invalid username/password/security token issue since they were able to get into Salesforce.com the first time without a problem.

 

Has anyone else run into this problem?

 

Thanks,
Eric

Best Answer chosen by Admin (Salesforce Developers) 
PeanutmanPeanutman

Hi Samantha,

 

About two weeks ago, when I tried logging in as another user, I kept getting logged out of Salesforce.com and had to keep logging back in again. I called up basic support about this, and they sent me the instructions below. I followed them, and it cleared things up for me. Hopefully it will help you out too!

 

Eric

 

 

This is a guide to optimal browser settings in Microsoft Internet Explorer 6 and 7 that can help users who are having trouble.

 

If you are being presented with a blank screen when logging into salesforce.com or are logged out when trying to save items, follow these instructions below:

 

1. In the Browser Menu > click Help > then choose "About Internet Explorer". Ensure that the cipher strength is 128 bit. If it is not, go to ww.microsoft.com/windows/ie and upgrade to a 128 bit version.

 

IMPORTANT NOTE: If you follow the steps below and delete cookies if you have previously performed a Computer Activation you may be prompted to activate your computer again upon the next login.

 

In the Browser window click the Tools menu > Internet Options:

 

For IE 6:

 

General Tab:

 

1. In the "Temporary Internet Files" section > click the Settings button.

 

2. Select the "Every visit to the page" radio button and ensure there is enough disk space for the cache. The ideal cache size is between 20 and 50 megabytes (MB). (Make sure your computer has enough disk space on its hard drive.)

 

3. Click the OK button.

 

4. DO NOT PERFORM THIS STEP IF YOU WORKING THROUGH COMPUTER ACTIVATION ISSUES: Then on the General Tab > Temporary Internet Files > click the Delete Cookies button and Delete Files button.

 

5. Follow additional steps below for all other tabs

 

For IE 7:

 

General Tab:

 

1. In the "Browsing history" section > click the Settings button.

 

2. Select the "Every time I visit the webpage" radio button and ensure there is enough disk space for the cache. The ideal cache size is between 20 and 50 megabytes (MB). (Make sure your computer has enough disk space on its hard drive.)

 

3. Click the OK button.

 

4. Then back on the General Tab > in the Browsing History section > click the Delete button

 

5. In the new window click Delete Files for Temporary Internet File section.

 

6. DO NOT PERFORM THIS STEP IF YOU WORKING THROUGH COMPUTER ACTIVATION ISSUES: Then click Delete Cookies for the Cookie section.

 

7. Follow additional steps below for all other tabs.

 

The rest of the instructions are the same for IE6 and IE7:

 

Security Tab:

 

1. Click the "Internet" icon (represented by a globe graphic).

 

2. Click the Custom Level button.

 

3. Scroll almost to the bottom of the Settings box to "Active Scripting".

 

4. Ensure that the Enabled option is selected.

 

5. Now scroll to the option that says "Display Mixed Content" and make sure this is set to Enabled.

 

6. When you are finished, click the OK button.

 

7. Back on the Security Tab > click the "Trusted Sites" icon (represented by a check mark graphic).

 

8. Click the Sites button.

 

9. In the "Add this Web site to the zone" text box, enter "https://*.salesforce.com/" (without the quotation marks)

 

10. Click the Add button.

 

11. When you are finished, click the OK or Close button.

 

Privacy Tab:

 

1. Select "Advanced" button.

 

2. Check "Override automatic cookie handling" setting 3. Also check "Always allow session cookies".

 

Advanced Tab:

 

1. Scroll to the bottom of the Settings window 2. The "Do not save encrypted pages to disk" check box should NOT be selected 3. The "Empty Temporary Internet Files Folder when browser is closed" check box should be selected 4. The "Use SSL 2.0" and "Use SSL 3.0" check boxes should be selected

 

Click OK to close the Internet Options window

 

Close all open Browser windows

 

Re-launch Internet Explorer

 

Login to salesforce.com

 

NOTES:

 

If problems persist and you know you are connecting to the Internet using a Proxy server, you can also make the following change to your settings.

 

1. Click the Tools menu, and select Internet Options.

 

2. Click the Advanced Tab, and scroll approximately half-way down the Settings box.

 

3. Select the "Use HTTP 1.1 through proxy connections" check box.

 

If you are using IE7 and experience page errors while running S-Controls in Internet Options in your browser go to the Advanced Tab and uncheck "Enable native XMLHTTP support". Try your S- Control again.

All Answers

Wallace.WoodWallace.Wood

I have 2 users with this same problem.  Reset passwords, get new Security token, verify uninstall, reinstall, etc. and do it again...  same results.  Failure.

 

I am an admin and it doesn't even try to log me in!  Goes straight to SF home page with it's seven annoying errors. (Turn on debugging in the browser.)

 

Using:

  • IE 6.0.2900.5512.xpsp_sp3_gdr.080814-1236  cipher strength 128-bit
  • Latest and greatest connector

 

 

Carolina_GirlCarolina_Girl
Has anyone found a fix for this? I have a user who is experiencing the same thing. Outlook 2003 with Windows XP. We reinstalled the Outlook connector, then reset the password and security token - which worked for 24 hours and then quit.
TechnogirlTechnogirl
I am having the same issue as Peanutman describes.  I am able to successfully log into Salesforce either through Outlook or Internet Explorer, but when i click on a link, it will log me out.  At that point, the software does not even recognize my login password and i am forced to cancel out of the link and do other things.  this has been very frustrating! 
Wallace.WoodWallace.Wood

SF tech support knows about this issue.  dlls are not registered properly.

Here is what I did

1- Delete the salesforce.com folder from Outlook by right clicking on it and click on delete
2- Close Outlook and make sure its not running in the task manager | processes tab (outlook.exe)
3- Register the following files by copy pasting each line in the Run command
Click on Start | Run

copy and paste each line and click on ok to register the file

 

regsvr32 "C:\WINDOWS\system32\SftTree_IX86_U_50.ocx"
regsvr32 "C:\Program Files\salesforce.com\3rd Party\SfdcRm.dll"
regsvr32 "c:\Program Files\salesforce.com\o3\OlMinAddin.dll"

 

4- Reopen outlook and go to Tools | salesforce options, click on the "email" tab and check the box for the "Add salesforce folder in outlook"
5- Close and reopen outlook

 

worked for me.

 

TechnogirlTechnogirl
thank you for the information.  we tried the steps, but am still getting logged out.  any other suggestions?
Carolina_GirlCarolina_Girl

Here's what SF support gave me to try. We used the "Quick Fix" which did work, but seems like brute force.

 

Problem

  User sees "Revocation information for the security certificate for this site is not available.  Do you want to proceed?" when openning Outlook or trying to open "Salesforce Options" from Outlook.

 

Quick Fix - Disable the Server Certificate check in I.E.

From Internet Explorer, click on Tools | Internet OptionsClick on Advanced tab Scrol down, under "Security" settingsUncheck the box in front of "Check for Server Certificate Revocation"Click on OK

 

Possible Causes & Alternate Fixes

 

Proxy is caching an old certificate

Clear the cache on the proxy.

 

Bad Proxy Setting

In your browser go to Tools - Internet Options - Connections and click the LAN settings button.

Confirm proxy setting for you LAN.

 

Proxy is accidentally turned on

Go to Start on your computer and click on Run.

Type regedit and click OK.In the registry editor navigate to the registry key "ProxyEnable" under "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings".

Make sure its value is 0. If not click on the name ProxyEnable and set the value to 0 close the editor.

 

Outlook lack security rights to install certificate Check what user is being used to run Exchange. ("local machine" may not be sufficient) Replace user with an admin user, or at least a user with certificate install rights.

 

Bad Plugin

InstallUninstall and reinstall the plugin.

 

Time Mismatch

Compare local machine and/or BIOS clock with a machine that's working.

Change to match the working machine. (they need to match Salesforce.com's clock)

 

VPN Interference

Disconnect from VPN

Reinstall the Certificate

 

PeanutmanPeanutman

Hi Carolina_Girl,

 

I just got an e-mail from Salesforce.com Support about this yesterday. The newest release of the Outlook Edition (Version 3.2.513) fixes this problem.

 

Per the Outlook Edition Release Notes:

Fixed an issue that forced users to log in to Salesforce when they attempted to open a lookup window from a salesforce.com folder in Connect for Outlook.

 

The rep sent me the instructions, and I tried them out on one of my users with this problem, and the issue is resolved. Feel free to reference my case number (02449028) or send me an e-mail direclty at eschubert@ahslink.com.

 

Thanks Salesforce.com!

Eric

SamanthaCPSamanthaCP

I'm having the same issue, but don't have Connect for Outlook. Just accessing my org via explorer I get logged out when clicking on links/buttons/tabs etc. It's driving me insane. Emailed support twice but haven't had a response yet.

It started yesterday quite suddenly, directly after I created the user profile for this community, linked to my account. I don't know if these are related or not though.

 

Samantha

PeanutmanPeanutman

Hi Samantha,

 

About two weeks ago, when I tried logging in as another user, I kept getting logged out of Salesforce.com and had to keep logging back in again. I called up basic support about this, and they sent me the instructions below. I followed them, and it cleared things up for me. Hopefully it will help you out too!

 

Eric

 

 

This is a guide to optimal browser settings in Microsoft Internet Explorer 6 and 7 that can help users who are having trouble.

 

If you are being presented with a blank screen when logging into salesforce.com or are logged out when trying to save items, follow these instructions below:

 

1. In the Browser Menu > click Help > then choose "About Internet Explorer". Ensure that the cipher strength is 128 bit. If it is not, go to ww.microsoft.com/windows/ie and upgrade to a 128 bit version.

 

IMPORTANT NOTE: If you follow the steps below and delete cookies if you have previously performed a Computer Activation you may be prompted to activate your computer again upon the next login.

 

In the Browser window click the Tools menu > Internet Options:

 

For IE 6:

 

General Tab:

 

1. In the "Temporary Internet Files" section > click the Settings button.

 

2. Select the "Every visit to the page" radio button and ensure there is enough disk space for the cache. The ideal cache size is between 20 and 50 megabytes (MB). (Make sure your computer has enough disk space on its hard drive.)

 

3. Click the OK button.

 

4. DO NOT PERFORM THIS STEP IF YOU WORKING THROUGH COMPUTER ACTIVATION ISSUES: Then on the General Tab > Temporary Internet Files > click the Delete Cookies button and Delete Files button.

 

5. Follow additional steps below for all other tabs

 

For IE 7:

 

General Tab:

 

1. In the "Browsing history" section > click the Settings button.

 

2. Select the "Every time I visit the webpage" radio button and ensure there is enough disk space for the cache. The ideal cache size is between 20 and 50 megabytes (MB). (Make sure your computer has enough disk space on its hard drive.)

 

3. Click the OK button.

 

4. Then back on the General Tab > in the Browsing History section > click the Delete button

 

5. In the new window click Delete Files for Temporary Internet File section.

 

6. DO NOT PERFORM THIS STEP IF YOU WORKING THROUGH COMPUTER ACTIVATION ISSUES: Then click Delete Cookies for the Cookie section.

 

7. Follow additional steps below for all other tabs.

 

The rest of the instructions are the same for IE6 and IE7:

 

Security Tab:

 

1. Click the "Internet" icon (represented by a globe graphic).

 

2. Click the Custom Level button.

 

3. Scroll almost to the bottom of the Settings box to "Active Scripting".

 

4. Ensure that the Enabled option is selected.

 

5. Now scroll to the option that says "Display Mixed Content" and make sure this is set to Enabled.

 

6. When you are finished, click the OK button.

 

7. Back on the Security Tab > click the "Trusted Sites" icon (represented by a check mark graphic).

 

8. Click the Sites button.

 

9. In the "Add this Web site to the zone" text box, enter "https://*.salesforce.com/" (without the quotation marks)

 

10. Click the Add button.

 

11. When you are finished, click the OK or Close button.

 

Privacy Tab:

 

1. Select "Advanced" button.

 

2. Check "Override automatic cookie handling" setting 3. Also check "Always allow session cookies".

 

Advanced Tab:

 

1. Scroll to the bottom of the Settings window 2. The "Do not save encrypted pages to disk" check box should NOT be selected 3. The "Empty Temporary Internet Files Folder when browser is closed" check box should be selected 4. The "Use SSL 2.0" and "Use SSL 3.0" check boxes should be selected

 

Click OK to close the Internet Options window

 

Close all open Browser windows

 

Re-launch Internet Explorer

 

Login to salesforce.com

 

NOTES:

 

If problems persist and you know you are connecting to the Internet using a Proxy server, you can also make the following change to your settings.

 

1. Click the Tools menu, and select Internet Options.

 

2. Click the Advanced Tab, and scroll approximately half-way down the Settings box.

 

3. Select the "Use HTTP 1.1 through proxy connections" check box.

 

If you are using IE7 and experience page errors while running S-Controls in Internet Options in your browser go to the Advanced Tab and uncheck "Enable native XMLHTTP support". Try your S- Control again.

This was selected as the best answer
SamanthaCPSamanthaCP

Hi Peanutman, I made the changes in your prost and it seems to have worked, thanks for sharing!

Samantha

Bill DillonBill Dillon
Every time I send an email through SFDC the login screen pops up.  I don't have to login but can just close the window.  It is only happening on some pcs.  Has anyone had this issue?