+ Start a Discussion
DuFreyDuFrey 

Warning: The entity "bull" was referenced, but not declared.

I am using the • character entity which generates a bullet point in a Visualforce page which renders as a PDF. I am using like the following:

<div>&bull;<span class="tab"></span>&quot;<b>Content Site</b>&quot; means...

and I am get an the following warning: The entity "bull" was referenced, but not declared. I tried using &#149; and &#x2022; but those do not render correctly the bullet point in the PDF. I am unable to consistently generate the warning message either. I can generate the PDF 3 times and get the warning all three times or not at all without changing anything.

Any ideas what could be occurring?

Thanks.


harlequinharlequin
Have you tried:
 
Code:
<apex:outputText value="&bull;" escape="false" />

 
dchasmandchasman
Harlequin's suggestion is correct.

I believe the apparent inconsistency of the warning is because it happens when the page definition is first loaded into an application server's cache and there is a pool of machines that your requests get routed to and each machine has its own local cache.


Message Edited by dchasman on 11-26-2008 08:39 AM
DuFreyDuFrey
Thank you for the suggestion Harlequin and background info Doug.

I will try this idea and see if I receive any warning messages in my PDFs.

Thanks again.