+ Start a Discussion
FengFeng 

Select All CheckBox of Multiple ListViews and Component attribute default issues, bug?????

Hi All, not sure your guys find these issue,

1.  I had two ListViews on the Page.
E.g.:

Code:
<apex:page showHeader="true" tabstyle="Case">
<apex:ListViews type="Case" />
<apex:ListViews type="MyCustomObject__c" />
</apex:page>

both select all check boxes Action on the list (next to the Action Label on the header ) are not working,
it is working if only one listview in the page
I am using IE6
the error msg from IE is: elements.length is null or not an object

2. Component default value,
i add following attribute into the component: SomeComponent

Code:
<apex:attribute name="AttName" description="description" type="boolean" required="false" default="false"/>


 I use this in another component ,

Code:
<c:AttName .... required="{MyObject.FieldReturnBoolean__c}" />

 it returns following error

MyAnotherComponent: 0: Literal Value is required for attribute AttName in <c: SomeComponent> at Line X column Y

no error returns  once i removed the default="false" from the code,

Any Idea about these two issues? Bug?



Message Edited by Feng on 07-16-2008 08:45 PM

Message Edited by Feng on 07-16-2008 08:47 PM

Message Edited by Feng on 07-17-2008 01:30 PM
VarunCVarunC
Were you able to resolve this error, i'm also facing this issue ...
FengFeng

Which you refer to?  the second issue is not

we solved the first one by changing the javascript and point the Form object to correct one

VarunCVarunC
I was refering to the Literal error issue :) ... did you come to know why would that be happening ....  ?
FengFeng
no, what i did was removed the default value