+ Start a Discussion
HotnilleHotnille 

Problems importing my Excel .CSV file with leads....

I have been trying to import an Excel .CSV file into Salesforce but can't get it to work. When I reach the point (in the Wizard) where the system uploads the file and I have to map the fields - all fields is on one string. So I can't map my columns "First Name", "Last Name" and "Email".

Has anyone had the same problem and how did you solve it??
KoechlerKoechler
Hi
 
Im experiencing the same problem. Have you been able to find a solution?
 
Any help would be greatly appreciated.
 
Thanks,
Michael
madsmads

Hello everyone,

 

I have exactly the same problem. I put the correct SF fields into my columns but nothing....

 

does anybody know how to solve this?

 

Many thanks

Mads

 

 

SuperfellSuperfell
Are you sure you exported from excel with comma delimitors? sometimes i've seen tab delimitors get generated by excel.
madsmads

Hi,

 

thank you for your reply. I am sure I am exporting CSV, comma delimitors...I have tried many times now but still the same problem. When I see all the fields into one string, they actually are separeted by a comma...but all into one string so impossible to select them!

 

Can this be related to Excel 2003? 

 

Dunno what to do! :smileymad:

 

thank you

SuperfellSuperfell

Which version of excel are you using? (AFAIK, there is no excel 2003 on the mac), i just tried this with office 2008 on osx 10.5.6, and it worked fine (importing leads).

 

Have you tried the dataloader with your CSV file, does it show the same thing? 

benjaminrbenjaminr

- Mac OS X 10.5.6

- MS OFFICE (EXCEL:MAC 2008) Version 12

 

i have the same issue.

 

it shows all in one string and says "(col 0)" in the end.

 

i've tried comma separated, comma separated Windows & MS-DOS,  and in SF i tried ISO, UTF8 and UTF16

 

nothing worked :( 

 

SuperfellSuperfell
Can someone email a csv that they couldn't import, and their exact import steps, i tried this with office 2008 on OSX 10.5.6, and imported leads fine. sfell at salesforce.com
madsmads

Hello everyone.

 

Simon, thank you for your help and patience. I have Excel 2003, tried again  and couldn't do it. Ended up emailing the excel file to a colleague, he saved it in csv from his computerand emailed it back to me. That way it worked. I had import another file and again I couldn't save in csv from Excel. Yesterday I found a way though! :smileyhappy:

I saved my file in the OpenOffice equivalent of Excel. Then saved the file in csv. Once the file was saved, I opened it with note pad (I know...) and saved as csv again. This way it worked. Benjamin, you might give it a try...maybe you could skip the OpenOffice step? I know it's a bit long but at least it worked...

benjaminrbenjaminr
strange. i've opened the file with BBedit - safed it as windows linebreaks (CRLF) and encoding "western (windows latin 1)" and is still brings up the same error...
HotnilleHotnille

Hi all.

 

I managed to find the "bug". In my case it was a matter of changing the standard format from ISO to Unicode (in the wizard box) Then it worked! Salesforce could have saved me a lot of time putting this info online. I hope this helps you all.

 

benjaminrbenjaminr

hi there,

 

what excel version do you use? did you just export the CSV and than upload as unicode (UTF8 or 16?)

 

thanks

Benjamin

HotnilleHotnille

Hi Benjamin.

 

I tried all different kinds of Excel, on my PCs, on Macs etc. I had same problem on all of them until I chose UTF8 (I think, but could be 16).

 

Yes - same CSV that didn't work in ISO mode, imported perfectly when changing to UTF.

 

/Hotnille 

SuperfellSuperfell
IIRC, when you do the import, you can selected the encoding, this does need to match the encoding you used during the export/CSV output from Excel.
benjaminrbenjaminr

'ok guys, i'm close to freak out. this is not what a professional tool is ment to be... i've tried the standard format of the exported CSV with ISO, UTF8 & 16 and windows format.

 

i've converted it to Latin 1, UTF, unix, mac and windows line-breaks.

 

it just doesn't work out... 

 

i've spend the half time of my free trial now with this single file.....

 

what next?

HotnilleHotnille

Hmm.. sorry the hear that. I have a document from Salesforce support explaining how it is done in Europe, as there's different ways of doing it right US vs EU. There is a CSV file from Salesforce included as well - as it is supposed to be created.

 

Drop me an email at hotnille@hotmail.com and I will mail it to you. 

 

//Hotnille 

STARR_ManSTARR_Man
I attempted to use your "solution" and sadly it didn't work for me.

I have been using the import wizard for a long time with NO problems until recently. SF has been completely unhelpful with this.

Anyone else have a suggestion?

 

BrigitteBrigitte

I also have problems with importing excel. Could you please send me the document you received from Salesforce suppot.

 

Brigitte.Kaluza@tieto.com

 

 

Thanks a lot!!!

 

 

STARR_ManSTARR_Man

What SF sent me was a document explaining how to use the Excel Connnector for importing data. That tool is GREAT for some uses and I had already been using it for a "backdoor" tool for fixing some "minor" data problems but the tool is NOT a tool that is useful/workable (in my opinion) for data import. The Import Wizard is the tool I want/need to have working.

 

Now after my venting I have had huge support from SF regarding the Import Wizard problem. They did discover a "bug" that my circumstances encountered. They are looking into a solution and have given me a "workaround" solution (rather cumbersome, but appears to be working!). I hope the Import Wizard is fixed before 2010!

 

So talk to your sales rep and get them to look at my case and have SF see if your problem is the same as mine!

Good Luck! And post again if you need some other info!

 

 

LementoLemento

Export your Leads to Excel xls file. Open the file in Googledocs. Export csv from Googledocs. Use that one and it will work!

Tom Vanderbauwhede

LementoLemento

It didn't work out with the Googledocs version after all. The problem starts when you do the export from salesforce as a report. You have to choose csv non-locale, it's the 3rd option. I did my editing in Notepad en saved it. That was the only file that worked (in my case).

 

Tom

STARR_ManSTARR_Man

I'm not exactly sure what you are referring to with the GoogleDocs solution!?

The problem is with the Import Wizard of SalesForce NOT working properly.

I encountered a bug and SF has acknowledged the bug and is working on solving it.

I had been using the Import Wizard for more than 2 years without issue until the problem occured.

 

Thanks for the effort on your part though!

muc-mikemuc-mike
Solution:
Export with Excel in *.txt!
Then upload in Salesforces as csv (no file rename necessary).
The SF guys didn't mention this in their lousy Excle import description!
STARR_ManSTARR_Man

My issue is not with downloading from SF but uploading (Importing) into SF with the Import Wizard and matching on email address. I had using the import wizard for years and all of a sudden it crapped out!

 

I agree they leave some things to be desired in their documentation but this appears to have been a "BUG" they say they are going to fix. STILL waiting for that!

 

Thanks!

durlacherdurlacher

Hi,

 

I solved the problem as follows and see it as a bug in SFDC.

 

What Excel produces (at least in a German XLS-Version) if you select Save as CSV is a file in which values are separated using ;

 

What SFDC accepts or expects is a file in which values are either tab-separated (at least it worked in my case using TXT-files) or a CSV-file with real commma (,) as separator and " as text indicator.

 

It's a bug in my opinion because SFDC alsways proclains this as a standard method from Excel, i.e. it is a normal assumption that you can use any Excel 2003, 2007 or 2010, use its standard functionality and get the right format in any country in which SFDC is officially released (i.e. the cloud ;-).

 

Cheers

D aka Rolf

KilkkuKilkku

I faced the same "challenge" today and indeed the problem seems to be in the localized version of Excel. At least the Finnish one does the same and uses a semicolon instead of a colon.

 

I finally solved the problem by saving the excel file as a .txt with tab separation and that worked.

 

UTF-8 didn't work for some reason (umlauts like ä and ö didn't come through) but the ISO-8859-1 worked just fine.

 

So to be clear: if you have this problem, save the file as text with tab separation (translations vary locally, but the original is Tab Delimited Text). You can find it at least in Excel 2007 (win) and 2008 (Mac) under Save as...

 

And If you are the supplier of the product: if possible, tweak your systems so that they would accept also semicolons. I don't think anyone uses sarcastic smileys in their production versions... ;)

damosvasdamosvas

I used Notepad for the same issue and it worked. The fields were available for mapping. Thanks for this post!

monika.denos1.39681534910662E12monika.denos1.39681534910662E12
We are 2 years further and the bug still exsist, it is crazy.
I'm using MacOs 2011 - upgraded just this week my mac , and since then uploadig does not work. 
Have tried all the above suggested quick fixes without any luck.
If any of you have a better soluton then send the file to a collegue with a pc and then uplodaed from there, I would be delighted to hear it.
naerwenyanaerwenya
It is now December 2014 and this ridiculous issue is still unresolved. Given the fact that we pay to use SalesForce, it's high time for this to have been taken care of. Even when working around with Notepad and the Replace tool, I can't import because company names contain commas. I don't know whether enabling the use of different deliminators is a big technical problem that they haven't figured out in the five years since the opening post, but to me, it would make so much more sense to use semicolons or tabs as deliminators.
Christian Angele 7Christian Angele 7
I solved this by replacing all semicolon in my csv (which I saved from Excel) to "," and adding a " at the beginning and end of each line.

Before (did not work):
Name;Firstname;E-Mail;Comment
Miller;Michael;michael.miller@web.com;bla bla bla

After:
"Name","Firstname","E-Mail","Comment"
"Miller","Michael","michael.miller@web.com","bla bla bla"

I did this manually in Notepad, there weren't so many entries in my file.
There probably is a way to tell Excel, that the deliminator in the cvs should be a comma and that the fields should be enclosed by "". Does anyone know how to do that?
Thassiana BalbinoThassiana Balbino
Hi
I have opened a case about the same issue in the beginning of March and they have not been to provide me with a solution until now (our company has the Premier + support plan).
I have escalated the case in March the 12th and until now I have received no feedback from the tier 3 support team.
Our integration project is stuck because of this issue.
 
Thassiana BalbinoThassiana Balbino
Hi Everyone

Finally the guys from the support team provided me with instructions that could really solve the problem. It actually has to do with Windows regional settings, not with Salesforce:

Control Panel –> Clock, Language and Region –> Change the date, time, or number format

In the "Format" field, select English or any other language that admits commas as the delimitor of values (which is not the case with Portuguese or some European languages; those admit only semi-colons as delimitors). Then click on "Additional Settings" and select "commas" from the drop down.

Click on OK / Apply / Save.

Now all the CSV files you create by Clicking on "Save As" from an Excel spreadsheet will have commas (not semi-collons anymore) as delimitors and therefore they will be uploaded correctly into Salesforce.

This solution worked very well for me, all fields were mapped correctly.

What I do not understand is why this very simple instruction can not be found in SF's knowledge base.

After you generate the CSV files you need you can get back to the usual settings in your computer.

I hope I have helped somebody.

Thassiana



 
Audrey GrantAudrey Grant
Having the same problem, no matter what I do I can't seem to import leads. I keep getting this error regarding mapping the fields. I've tried so many things, I don't understand why it's not working:

User-added image

I've saved the file as .csv and mapped everything correctly (as far as I know!)
Nicolas NICAISENicolas NICAISE
C'est un problème classique de séparateur de champs dans le CSV. 
Solution : le temps de modifier et d'enregistrer votre fichier sous Excel, passez en CSV américain. Allez dans le panneau de configuration Windows, option international. Dans les options avancées vous pourrez changer le séparateur de point virgule à virgule. Vous devrez aussi dans le même écran changer le séparateur decimal de virgule à point (format des nombres américain).
Faites la manip inverse une fois votre CSV enregistré. Seul Excel exploite les paramètres du panneau de configuration, pas le Data loader.
Bon courage  !
Christian KleinChristian Klein
2016 and the problem is still existing. One would expect for the market leader to aknowledge that there are other countries than the US. The fact that this issue is pretty much one of the basic functions of sf is quite embarrassing...

Anyway, here's my solution: Save as CSV (seperated by semicolon), open in editor, replace all semicolons with commas, save again, import, done.
Maarten MeijerMaarten Meijer
6 months late but THANK YOU for this tip. Took me 2 hours to find out why it wasn't working.
Mounika Ganta 14Mounika Ganta 14
There is no action on data import wizard even though i click on launch wizard. It is not redirecting and no action. It remains on the same page. Can some one help me with this problem
Chrissy FantChrissy Fant
I had this problem and remembered that I had at one time changed my regional settings to be | delimited instead of , delimited.
Make sure Excel is closed.
Navigate to control panel.
Select 'Region and Language'
Click the 'Additional Settings' button.
Find the List separator and change it from whatever you have as a preferred delimiter such as a pipe (|)  to a comma (,)
Click OK.
Click OK.
Oleksandra LukavetskaOleksandra Lukavetska
Hello,

Try to transfer your data with the help of automated data migration service. It will able you to import the data from the files (e. g. CSV) or CRM systems with no time loss, delays in business processes, no “human mistakes” during the migration, etc.

So, pay attention to Data2CRM migration service at ApppExchange and migrate information to any Salesforce edition
https://appexchange.salesforce.com/appxListingDetail?listingId=a0N3A00000EjVSuUAN

​Best regards
 
David Nash 8David Nash 8
You can download it in any format and then convert to your desired one using Excel Converter even CSV.: https://www.coolutils.com/TotalExcelConverter (https://www.coolutils.com/TotalExcelConverter)
kylie jones 13kylie jones 13
XLS to VCF Converter Software is a special and well-intelligent tool. It changes contacts from Excel to VCF quickly. This Software is created by the professional experts to solve users' complication which comes in between XLS to the VCF migration process. Using Excel to vCard converter device to convert XLS / XLSX excel contacts files in the VCF file without missing any single contact information. Also, it compatible with Windows 10 versions. This tool provides a free demo application.
Get More Information:- Excel to VCF Converter
Zoran HadzicZoran Hadzic
Hello guys,
I resolved problem following advice of Lemento, It is work now..
 
Jefferson PSJefferson PS
The most practical way to solve this problem without having to install anything, just look for a site that converts XLS to CSV.
I did it through the website: https://convertio.co/pt/xlsx-csv/

And when I uploaded it to SF, it recognized all the fields in the CSV file.