+ Start a Discussion
ShabsMoiyed1916ShabsMoiyed1916 

Visual Force pages loading very slowly

Hi, We have customised salesforce functionalities using VisualForce. I am experiencing poor Performance of these pages. The pages loads up quite slowly compared to standard salesforce pages.  What could be the reason for such slow responses? Any help in this regard will be highly appreciated . I am also looking for a ways to check the page-size when they load up on the client. What could be the easiest way to do so.

 

I would like to know if anyone else has faced similar issues.

 Thanks  Shabs Moiyed

 

Ron HessRon Hess

Two tools come to mind. 

One is firefox+firebug  using the firebug "net" tab you can see how long your page loads, and how many bytes were sent over the wire.

 

the other place to look is 'view source' on your page after it loads, then at the very bottom of the page is a  the pagegen teim that occured on our servers. 

 

The time looks like this :

 

<!-- page generation time: 382ms -->

 

 

now, i have to ask how many records you are drawing on your page, this is most often the cause of a slow page load.

 

are you using tabPanel ?

 

are you showing > 100 records, if so have you considered paging thru the records with next/previous buttons

 

 

 

ShabsMoiyed1916ShabsMoiyed1916

Hi Ron,

We are showing 20 records at the moment per page and we are paging through the rest of records using the next and previous links.

 

regarding tab panel i will confirm and get back to you?

 

Thanks

 

Shabs

Ron HessRon Hess

how many miliseconds show at the bottom of the page?

 

ShabsMoiyed1916ShabsMoiyed1916

it is showing ~1450 ms

 

 

ShabsMoiyed1916ShabsMoiyed1916

I will send you the load time on all pages in a moment

 

thanks
Shabs

ShabsMoiyed1916ShabsMoiyed1916

The load timings on most of the pages ranges from 1450 ms to 1500ms

 

 

Thanks

Shabs

Ron HessRon Hess
can you run the system log and determine how many queries are running when this page loads?
paul-lmipaul-lmi
Hi Ron, I'm using a tabPanel, and according to the debug logs, each tab is loaded when the page loads.  This causes 4 separate queries to execute every time the page loads, instead of one query for the default tab.  Can you give some insight on how to better optimize this?  This setup currently adds around 100ms to the page load time, and that, on top of the existing spin-up time it takes to get all the CSS and JS files that Visualforce has to get into the user's browser, causes a bad first impression.  To top it off, I'm also using this in a home page custom component via iframe, so it's just a blank white entry until this widget is done loading.
CTU007CTU007

hi, I am having same issue, users are complaining.

 

Any solution?

 

 

my post

Keith987Keith987

Linking this old thread to by question on stackexchange Advice on speeding up Visualforce pages?