+ Start a Discussion
Steve_FinlaySteve_Finlay 

Non required input fields in Visualforce page not displayed on public site

This is my first attempt at creating a sites page.

I'm unable to get any non-required field to display on the public site. The required fields display ok. By 'required', I mean required as set in the custom object.

 

Here is the visualforce page code...

 

<apex:page showHeader="false" sidebar="false" standardController="Complaint__c">

    <h1>Online Complaint Handling</h1>

    <apex:form >

        <apex:outputText value="Are you logging the complaint for yourself?" />

        <apex:inputField value="{!Complaint__c.Logging_this_complaint_for_yourself__c}" />

        <br/>

         

        <apex:outputText value="Complainant First Name" />

        <apex:inputField value="{!Complaint__c.Complaint_First_Name__c}" />

        <br/>

        

        <apex:outputText value="Relationship to Caller" />

        <apex:inputField value="{!Complaint__c.Relationship_to_Caller__c}" />

        <br/>

         

        <apex:outputText value="Caller Name" />

        <apex:inputField value="{!Complaint__c.Caller_Name__c}" />

        <br/>

         

        <apex:outputText value="Caller State" />

        <apex:inputField value="{!Complaint__c.Caller_State__c}" />

        <br/>

        

        <apex:outputText value="Date of Call" />

        <apex:inputField value="{!Complaint__c.Date_of_Call__c}" />

        <br/>

        

    </apex:form>

</apex:page>

 

 

Only the Caller_Name__c and the Date_of_Call__c input fields display on the public site, and they are the only 'required' fields from the Complaint custom object. The other input fields such as Complaint_First_Name__c just don't display on the public site.

 

The page displays correctly if previewed from within Salesforce via https://ap1.salesforce.com/apex/Complaint for example.

 

Can anyone offer some help as to what is wrong?

 

Steve

 

 

ScoobieScoobie

This sounds like a field security issue.

 

Check one of the fields not displaying to see which profiles it is specified as hidden in and make it viewable then check your VF page again and repeat until you find the profile controlling these fields.

 

If that doesn't work then we may need to look into other less obvious solutions

BrewnixBrewnix

I am having the exact same issue... any updates on this?

chokchok

Thank you!