+ Start a Discussion
Dovid BDovid B 

controller namespace conflict

We are using OrchestraCMS for our website CMS tool on Sites. However we need to add a custom component with its own custom controller to the page template. The problem is when I try to use it in Orchestra I get the following error:

 

Custom Controller cms.mycustomcontroller does not exist.

 

This makes perfect sense as mycustomcontroller is not in the cms namespace. That's OrchestraCMS's namespace. I am not using any name space. But it seems to insist that all controllers on the page are in the cms namespace. OrchestraCMS says this is outside what they will support.

 

So any ideas on how to have a custom component controller with a different namespace (or no namespace) on a page with a namespaced custom controller?

 

Thanks,

Dovid

saraha@groupesci.comsaraha@groupesci.com

Have you tried just referring to mycustomcontroller with no namespace?

Dovid BDovid B

yes, of course. That is what I did. But since the page controller is using the cms namespace, it seems to think every controller should be part of that namespace.

joshbirkjoshbirk

It may be necessary to create a new managed package, put your component in there - and then use the managed package.  You might pass that by the OCMS guys first.  I haven't tried that myself, but had a fellow developer recommend it as a possible solution for that scenario.

jwetzlerjwetzler

Yes that will probably work as a workaround though it's of course not ideal.  I would try that to unblock yourself but please log a case with support.

Dovid BDovid B

okay, I'll look into that. With whom can I log a support case? OCMS won't support this and last time I tried using SFDC support for a dev issue, they said they also don't support development.

jwetzlerjwetzler

It sounds like a salesforce problem not an OCMS problem.  And salesforce definitely does support dev issues like this so give it a shot.  Send me a private message if they tell you the same thing.

GregWGregW

Dovid,

 

I manage the developer support team here at Salesforce.  Sorry you had a poor experience contacting support in the past.  Based on what I have read on this post this looks like it falls well within what we support and help with.  Pleaes log a case for this issue and reply to me with the case number.  I will make sure it gets reviewed by a resource on my team.   If you have an old case number, send that over as well, I will figure out what happened.

 

Thanks

 

-Greg

Dovid BDovid B

ok, I just logged the case but don't have a case number yet.

 

The other dev issue was not related to this. The support agent I got was trying to find a solution even though it was outside his realm of expertise. In the end it seems like it was an issue with our dns provider which it looks like we solved.

 

Thanks for your help.

GregWGregW

Great - Just let me know when you get confirmation on the case number back. 

 

-Greg

Dovid BDovid B
Here is my case number: 05032653