+ Start a Discussion
vfnevfne 

Unable to migrate components from Developer to professional edition

I am trying to move Custom objects, tabs and visual force pages form Develop Edition to Professional Edition using Force.com IDE embedded in eclipse.

 

The problem is that when i fully import the devleop edition in Eclipse (whn creating a new Force.com project, i chose to get all apex classes, components,...) and try to "Deploy to server" to my professional edition, it only displays the VisualForce pages which obvisouly returns an error since the custom objects did not yet load and it they are not listed (view image)..

 

This sounds like a dependency problem where i use the custom objects that i created in VisualForce pages.. can anyone plz detail how to fix this (i dperecate the use of unmanaged packages and the force.com migration tool seems to do the same thing as the force.com ide)

 

I would appreciate any advise

 

 

 

Best Answer chosen by Admin (Salesforce Developers) 
theitdeptrockstheitdeptrocks

Make sure that the custom objects (and all other dependencies - layouts, components, etc) are added to your project.  Then deploy all at the same time.

 

1)  Right click on your Salesforce project under "Package Explorer"
2)  Force.com --> Add/Remove Metadata Components...
3)  Click on the "Add/Remove..." button
4)  Are all of the boxes checked or just those for the VF pages?  Check off what you want and click on the "OK" buttons.
5)  You'll be prompted to refresh the project, select "Yes"
6)  You may be prompted that you have open files and a resfresh may replace those files if they haven't been saved