+ Start a Discussion
West415West415 

New to SF - problem with using component in my Visual Force Page

Hi,

 

I'm new to developing applications with salesforce and have a question that I was hoping someone could understand.  I do have some general programming experience, but just not within salesforce.

 

I cloned an existing Visual Force Page and it works fine for the most part, but when I add this component to the page and tried to run the page in my browser I get a default maintenance page.  There obviously is an error or something is not referenced that needs to be in my page.  Below is the snippet where I have this component being declared.

 

 <div id="accordion_menu">
      <div>
           <as2:SampleMenu ></as2:SampleMenu>
       </div>
  </div>

 

If I remove "  <as2:SampleMenu ></as2:SampleMenu>" the page runs fine, but when I added the above component reference (hope I'm saying that right) I get the default maintenance page saying  "Sorry for the inconvenience. We'll be back shortly. Please email us if you need to get in touch."

 

This error/maintenance page isn't helpful at all so I'm somewhat fishing in terms of what could be wrong.   This component is used in the VF page that I cloned and works there, but it's not working for me in my new page. 

 

 

  1. Is there somewhere I need to map components to the page or something to make them available or something else I need to check for, some reference maybe?

  2. Is there a way to get more meaningful error messages when something goes wrong like this?

 

 

AJSFDCAJSFDC

Are you trying include custom component in your VF page. If yes below is the syntax.

 

<c:compName record="Account" />

West415West415

Yes, I'm trying to include the custom component, but two things.

 

"as2" is the namespace <as2:SampleMenu ></as2:SampleMenu> and when I run the page in my browser I get the salesforce maintenance page as I mentioned in my initial post.

 

Also, this component was created by someone else, and it seems to be "installed",  I can't see what's inside of it.  I when to the components section in salesforce, but it doesn't let me see the code.  It's as if it's packaged or something.  The component also doesn't use any attribute like "record" like you have defined "<c:compName record="Account" />"