+ Start a Discussion
LaaralLaaral 

API Version 25 or 27?

Hi, I wanted to know how these two version differ? I noticed that some of my apex classes use version 25 and some of my triggers 25 or 27? We are taking project from sandbox to production, so I'm thinking should I update these or ?

Best Answer chosen by Admin (Salesforce Developers) 
Sandeep001Sandeep001

SFDC release new features 3 times in an year (Winter, Spring & Summer). ver 25.0 is Summer 12 and ver 27.0 is Spring 13 release.

 

Have a look at this:

 

http://www.salesforce.com/us/developer/docs/api/Content/whats_new.htm

 

SFDC maintains backward compatibility with older version, so you can keep your triggers of 25.0 version as well in your instance.

All Answers

Sandeep001Sandeep001

SFDC release new features 3 times in an year (Winter, Spring & Summer). ver 25.0 is Summer 12 and ver 27.0 is Spring 13 release.

 

Have a look at this:

 

http://www.salesforce.com/us/developer/docs/api/Content/whats_new.htm

 

SFDC maintains backward compatibility with older version, so you can keep your triggers of 25.0 version as well in your instance.

This was selected as the best answer
sfdcfoxsfdcfox
More to the point,if you don't know the difference between two versions, don't upgrade your code's version. This can cause your code to fail deployment. For example, changing from v23 to v28 can cause tests to fail, which would halt deployment. If you change the version of the code, you will also have to test the code to make sure it still works and fix it if it doesn't.